summaryrefslogtreecommitdiffstats
path: root/recipes/linux-libc-headers
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-01-08 14:32:18 -0800
committerKhem Raj <raj.khem@gmail.com>2011-01-08 14:33:14 -0800
commit52bca7257cdc5920e56d87b3f8a2b3c413dca305 (patch)
tree7781652e666e6be04ff76e15c4eb9b0ffcd3a66b /recipes/linux-libc-headers
parentec01c2cced96217d65212fd862414ff0d0387ae3 (diff)
downloadopenembedded-52bca7257cdc5920e56d87b3f8a2b3c413dca305.tar.gz
linux-libc-headers_2.6.37.bb: New recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/linux-libc-headers')
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.37.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.37.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.37.bb
new file mode 100644
index 0000000000..c8b38714c6
--- /dev/null
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.37.bb
@@ -0,0 +1,28 @@
+require linux-libc-headers.inc
+
+# untested for non nios2 systems
+DEFAULT_PREFERENCE = "-1"
+INHIBIT_DEFAULT_DEPS = "1"
+DEPENDS += "unifdef-native"
+PR = "r0"
+
+COMPATIBLE_TARGET_SYS = "."
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/${P}.tar.bz2;name=kernel \
+ file://defconfig "
+
+SRC_URI[kernel.md5sum] = "c8ee37b4fdccdb651e0603d35350b434"
+SRC_URI[kernel.sha256sum] = "edbf091805414739cf57a3bbfeba9e87f5e74f97e38f04d12060e9e0c71e383a"
+
+S = "${WORKDIR}/linux-${PV}"
+
+do_configure() {
+ cd ${S}
+ oe_runmake allnoconfig ARCH=$ARCH
+}
+
+do_compile () {
+}
+
+do_install() {
+ oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
+}