aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexec-tools/files/fix-arm-arch-detection.patch
diff options
context:
space:
mode:
authorKlaus Kurzmann <mok@fluxnetz.de>2009-12-15 14:48:49 +0100
committerKlaus Kurzmann <mok@fluxnetz.de>2009-12-15 14:48:49 +0100
commit2598548bd9e250da9c2eb1c1b83f8bd97a937151 (patch)
tree24b5b784b3a4b44b0ea353405d4f8d5a4ebc7dd1 /recipes/kexec-tools/files/fix-arm-arch-detection.patch
parent0bad67eed30abf02e5b32400263642b3b6aa2dc5 (diff)
parent54fa869952dc6b7c2f05018f65434877257d44de (diff)
downloadopenembedded-2598548bd9e250da9c2eb1c1b83f8bd97a937151.tar.gz
Merge branch 'martin_jansa/srcpv' into shr/merge
Conflicts: conf/distro/include/angstrom-2008-preferred-versions.inc recipes/uclibc/uclibc_nptl.bb Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes/kexec-tools/files/fix-arm-arch-detection.patch')
-rw-r--r--recipes/kexec-tools/files/fix-arm-arch-detection.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/kexec-tools/files/fix-arm-arch-detection.patch b/recipes/kexec-tools/files/fix-arm-arch-detection.patch
new file mode 100644
index 0000000000..6116c5bb84
--- /dev/null
+++ b/recipes/kexec-tools/files/fix-arm-arch-detection.patch
@@ -0,0 +1,17 @@
+--- kexec-tools/kexec/phys_arch.c.old 2008-07-15 02:46:43.000000000 +0200
++++ kexec-tools/kexec/phys_arch.c 2009-10-04 23:58:04.000000000 +0200
+@@ -13,9 +13,12 @@
+ return -1;
+ }
+
+- for (i = 0; arches[i].machine; ++i)
+- if (strcmp(utsname.machine, arches[i].machine) == 0)
++ for (i = 0; arches[i].machine; ++i) {
++ if ((strcmp(arches[i].machine, "arm") == 0) && (strncmp(utsname.machine, arches[i].machine, 3) == 0))
++ return arches[i].arch;
++ if (strcmp(utsname.machine, arches[i].machine) == 0)
+ return arches[i].arch;
++ }
+
+ fprintf(stderr, "Unsupported machine type: %s\n",
+ utsname.machine);