aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ezx/ezx-gen-blob_git.bb
diff options
context:
space:
mode:
authorAntonio Ospite <ospite@studenti.unina.it>2010-06-16 16:50:03 +0200
committerAntonio Ospite <ospite@studenti.unina.it>2010-06-20 18:45:49 +0200
commit7451853acecd4a26860afc0dbaeafbf6e32170ae (patch)
tree918f67d564099b1155c40695cdf09bc4cd388dc4 /recipes/ezx/ezx-gen-blob_git.bb
parentc5955cfe486cb84ba27ad0692ceecdaab779bb99 (diff)
downloadopenembedded-7451853acecd4a26860afc0dbaeafbf6e32170ae.tar.gz
ezx: replace ezx-gen-blob_svn.bb with ezx-gen-blob_git.bb
gen-blob is now at git.openezx.org, replace the old svn recipe with one which fetches the code from the git repository. Signed-off-by: Antonio Ospite <ospite@studenti.unina.it> Acked-by: Michael 'Mickey' Lauer <mlauer@vanille-media.de>
Diffstat (limited to 'recipes/ezx/ezx-gen-blob_git.bb')
-rw-r--r--recipes/ezx/ezx-gen-blob_git.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/ezx/ezx-gen-blob_git.bb b/recipes/ezx/ezx-gen-blob_git.bb
new file mode 100644
index 0000000000..5ebcad100c
--- /dev/null
+++ b/recipes/ezx/ezx-gen-blob_git.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Generic Blob [Bootloader] for the Motorola EZX platform"
+SECTION = "bootloaders"
+AUTHOR = "OpenEZX Team"
+HOMEPAGE = "http://people.openezx.org/wyrm/gen-blob"
+LICENSE = "GPL"
+PROVIDES = "virtual/bootloader"
+DEPENDS = "virtual/kernel"
+SRCREV = "48d1cf4dbc8228b982ff40c36922769f70347da1"
+PV = "1.0.0+gitr${SRCPV}"
+PR = "r0"
+PE = "1"
+
+SRC_URI = "\
+ git://git.openezx.org/gen-blob.git;protocol=git;branch=master \
+ file://remove-bogus-sed.patch \
+"
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+EXTRA_OECONF = "\
+ --with-board=lubbock \
+ --with-cpu=pxa262 \
+ --with-linux-prefix=${STAGING_KERNEL_DIR} \
+ --enable-usb \
+"
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 src/blob/blob-a780 ${DEPLOY_DIR_IMAGE}/gen-blob-for-1stgen.${SRCDATE}
+ install -m 0644 src/blob/blob-a1200 ${DEPLOY_DIR_IMAGE}/gen-blob-for-2ndgen.${SRCDATE}
+}
+
+addtask deploy before do_build after do_compile
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"