aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome/pyorbit_2.24.0.bb
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2008-11-15 18:23:17 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-11-15 18:23:17 +0100
commita25da5c491ac2a3820be7aaa7fa507fe7ca8b354 (patch)
treed8162d4d8d6aaf5f129e203b6bc9d3ccead522f7 /packages/gnome/pyorbit_2.24.0.bb
parent9e167064390ce3bff7425be5c002ed3f1e7eb1d1 (diff)
parent828ced10e6eaf2048a8fd7ee7263807fab9d784d (diff)
downloadopenembedded-a25da5c491ac2a3820be7aaa7fa507fe7ca8b354.tar.gz
Merge commit 'origin/org.openembedded.dev' into holger/openmoko-merges
Diffstat (limited to 'packages/gnome/pyorbit_2.24.0.bb')
-rw-r--r--packages/gnome/pyorbit_2.24.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/gnome/pyorbit_2.24.0.bb b/packages/gnome/pyorbit_2.24.0.bb
new file mode 100644
index 0000000000..fe6e2d1b0b
--- /dev/null
+++ b/packages/gnome/pyorbit_2.24.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Python Orbit bindings"
+LICENSE = "LGPL"
+
+PR = "r0"
+
+inherit gnome distutils-base pkgconfig
+
+SRC_URI += "file://acinclude.m4"
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+EXTRA_OEMAKE = "-e"
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+ export HOST_SYS=${HOST_SYS}
+ export BUILD_SYS=${BUILD_SYS}
+ export CC=${TARGET_PREFIX}gcc
+ autotools_do_configure
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/pyorbit-2
+ install -m 0644 src/pyorbit.h ${STAGING_INCDIR}/pyorbit-2
+ autotools_stage_all
+}