aboutsummaryrefslogtreecommitdiffstats
path: root/docs
diff options
context:
space:
mode:
authorChase Maupin <chasemaupin03@gmail.com>2010-05-26 03:09:33 +0000
committerDenys Dmytriyenko <denis@denix.org>2010-05-28 12:00:34 -0400
commit42d3b4431399f1da9097051765e54fea3917efe2 (patch)
treeffba1686c1ca6733c10284c49eb874f6ed2f4ae5 /docs
parentc39f6ea2eeb9807ccdd2232ea6485d3b8439351d (diff)
downloadopenembedded-42d3b4431399f1da9097051765e54fea3917efe2.tar.gz
docs/metadata: Fix documentation errors
* Fixed up typos and other errors in the documentation. Acked-by: Koen Kooi <k-kooi@ti.com> Signed-off-by: Chase Maupin <chase.maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denis@denix.org>
Diffstat (limited to 'docs')
-rw-r--r--docs/usermanual/chapters/metadata.xml18
1 files changed, 9 insertions, 9 deletions
diff --git a/docs/usermanual/chapters/metadata.xml b/docs/usermanual/chapters/metadata.xml
index bbf6f733bb..794c66ce15 100644
--- a/docs/usermanual/chapters/metadata.xml
+++ b/docs/usermanual/chapters/metadata.xml
@@ -95,7 +95,7 @@
<para>OpenEmbedded has files ending with <emphasis>.conf</emphasis>,
<emphasis>.inc</emphasis>, <emphasis>.bb</emphasis>
- and<emphasis>.bbclass</emphasis>. The syntax and semantics of these files
+ and <emphasis>.bbclass</emphasis>. The syntax and semantics of these files
are best described in the <ulink
url="http://bitbake.berlios.de/manual"><application>BitBake</application>
manual</ulink>.</para>
@@ -111,7 +111,7 @@
<section id="metadata_writing_data">
<title>Writing Meta Data (Adding packages)</title>
- <para>This page will guide you trough the effort of writing a .bb file or
+ <para>This page will guide you through the effort of writing a .bb file or
<emphasis>recipe</emphasis> in BitBake speak.</para>
<para>Let's start with the easy stuff, like the package description,
@@ -128,23 +128,23 @@ DEPENDS = "gtk+"
RDEPENDS = "cool-ttf-fonts"
</screen> The package needs gtk+ to build ('DEPENDS') and
requires the 'cool-ttf-fonts' package to run ('RDEPENDS'). OE will add
- run-time dependencies on libraries on its own via the so called
- <emphasis>shlibs</emphasis>-code, but you need to specify everything other
+ run-time dependencies on libraries on its own via the so called
+ <emphasis>shlibs</emphasis>-code, but you need to specify everything else
by yourself, which in this case is the 'cool-ttf-fonts' package.</para>
<para>After entering all this OE will know what to build before trying to
build your application, but it doesn't know where to get it yet. So let's
add the source location: <screen>
SRC_URI = "http://www.host.com/foo/files/${P}.tar.bz2;md5sum=yoursum"
- </screen> This will tell the fetcher to where to download the
+ </screen> This will tell the fetcher where to download the
sources from and it will check the integrity using md5sum if you provided
the appropriate <emphasis>yoursum</emphasis>. You can make one by doing
<screen>md5sum foo-1.9.tar.bz2</screen> and replacing
<emphasis>yoursum</emphasis> with the md5sum on your screen. A typical
- md5sum will look like this: <screen>a6434b0fc8a54c3dec3d6875bf3be8mtn </screen>Notice
- the <emphasis>${P}</emphasis> variable, that one holds the package name,
- <emphasis>${PN}</emphasis> in BitBake speak and the package version,
- <emphasis>${PV}</emphasis> in BitBake speak. It's a short way of writing
+ md5sum will look like this: <screen>a6434b0fc8a54c3dec3d6875bf3be868 </screen>Notice
+ the <emphasis>${P}</emphasis> variable holds the package name
+ (<emphasis>${PN}</emphasis> in BitBake speak) and the package version
+ (<emphasis>${PV}</emphasis> in BitBake speak). It's a short way of writing
<emphasis>${PN}-${PV}</emphasis>. Using this notation means you can copy
the recipe when a new version is released without having to alter the
contents. You do need to check if everything is still correct, because new