aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2011-02-25 08:09:35 -0700
committerChris Larson <chris_larson@mentor.com>2011-02-25 08:14:16 -0700
commitcec0767b1a223289595fa56cda1ed1d9bc8ad2c3 (patch)
tree333c92a4f024c364b3c65f33db21555a99e80319 /classes
parent4614343e9455ef154a18826c57cbd9474858da27 (diff)
downloadopenembedded-cec0767b1a223289595fa56cda1ed1d9bc8ad2c3.tar.gz
Revert "autotools: symlink where we can"
This is nice in theory, but there's a risk that a broken source tree could try to modify the files through the symlinks, screwing up everybody else using them. Of course, per-recipe sysroots would resolve this, so we can revisit this if/when that gets implemented. This reverts commit 302395545185b4e85bf76a8f319bc71bd3a7be1d. Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'classes')
-rw-r--r--classes/autotools.bbclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/classes/autotools.bbclass b/classes/autotools.bbclass
index a88a4d1e30..974458928a 100644
--- a/classes/autotools.bbclass
+++ b/classes/autotools.bbclass
@@ -137,11 +137,11 @@ oe_autoreconf () {
if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
: do nothing -- we still have an old unmodified configure.ac
else
- echo "no" | glib-gettextize --force
+ echo "no" | glib-gettextize --force --copy
fi
else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
if [ -e ${STAGING_DATADIR}/gettext/config.rpath ]; then
- ln -sf ${STAGING_DATADIR}/gettext/config.rpath ${S}/
+ cp ${STAGING_DATADIR}/gettext/config.rpath ${S}/
else
oenote ${STAGING_DATADIR}/gettext/config.rpath not found. gettext is not installed.
fi
@@ -151,9 +151,9 @@ oe_autoreconf () {
for aux in m4 `sed -n -e '/^[[:space:]]*AC_CONFIG_MACRO_DIR/s|[^(]*([[]*\([^])]*\)[]]*)|\1|p' $CONFIGURE_AC`; do
mkdir -p ${aux}
done
- autoreconf -Wcross --verbose --install --symlink --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed."
+ autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed."
if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
- intltoolize --force --automake
+ intltoolize --copy --force --automake
fi
}