aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-19 19:50:41 -0700
committerChris Larson <chris_larson@mentor.com>2011-02-16 15:00:42 -0700
commit302395545185b4e85bf76a8f319bc71bd3a7be1d (patch)
treec674a179fdb6edd5f07c21236253d18570a1bc07 /classes
parent80549f1f6f33061a73b386e1fcb2c4e3e25ae362 (diff)
downloadopenembedded-302395545185b4e85bf76a8f319bc71bd3a7be1d.tar.gz
autotools: symlink where we can
Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'classes')
-rw-r--r--classes/autotools.bbclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/classes/autotools.bbclass b/classes/autotools.bbclass
index 974458928a..a88a4d1e30 100644
--- a/classes/autotools.bbclass
+++ b/classes/autotools.bbclass
@@ -137,11 +137,11 @@ oe_autoreconf () {
if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
: do nothing -- we still have an old unmodified configure.ac
else
- echo "no" | glib-gettextize --force --copy
+ echo "no" | glib-gettextize --force
fi
else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
if [ -e ${STAGING_DATADIR}/gettext/config.rpath ]; then
- cp ${STAGING_DATADIR}/gettext/config.rpath ${S}/
+ ln -sf ${STAGING_DATADIR}/gettext/config.rpath ${S}/
else
oenote ${STAGING_DATADIR}/gettext/config.rpath not found. gettext is not installed.
fi
@@ -151,9 +151,9 @@ oe_autoreconf () {
for aux in m4 `sed -n -e '/^[[:space:]]*AC_CONFIG_MACRO_DIR/s|[^(]*([[]*\([^])]*\)[]]*)|\1|p' $CONFIGURE_AC`; do
mkdir -p ${aux}
done
- autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed."
+ autoreconf -Wcross --verbose --install --symlink --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed."
if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
- intltoolize --copy --force --automake
+ intltoolize --force --automake
fi
}