aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2010-02-14 14:03:09 +0100
committerStefan Schmidt <stefan@datenfreihafen.org>2010-02-14 14:03:09 +0100
commitc552fa102d908a2f303366cb8100d688b1fe0323 (patch)
treec3a71921bd89f9c32c6cb2ebb82e739a7b16319a
parentf9b0726bba7bb6c46c9e5cae5ee225fb07825246 (diff)
parentc9f8b48bbda14dfd9cab557b14b8fb81dbfee208 (diff)
downloadopenembedded-c552fa102d908a2f303366cb8100d688b1fe0323.tar.gz
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org.openembedded.dev
-rw-r--r--recipes/kexecboot/device_table-oldmmc.txt36
-rw-r--r--recipes/kexecboot/initramfs-kexecboot-image.bb9
-rw-r--r--recipes/kexecboot/kexecboot.inc32
3 files changed, 25 insertions, 52 deletions
diff --git a/recipes/kexecboot/device_table-oldmmc.txt b/recipes/kexecboot/device_table-oldmmc.txt
deleted file mode 100644
index 2b61c01849..0000000000
--- a/recipes/kexecboot/device_table-oldmmc.txt
+++ /dev/null
@@ -1,36 +0,0 @@
-#<path> <type> <mode> <uid> <gid> <major> <minor> <start> <inc> <count>
-#/dev/mem c 640 0 0 1 1 0 0 -
-#
-#type can be one of:
-# f A regular file
-# d Directory
-# c Character special device file
-# b Block special device file
-# p Fifo (named pipe)
-
-/dev d 755 0 0 - - - - -
-/dev/initctl p 600 0 0 - - - - -
-/dev/apm_bios c 660 0 46 10 134 - - -
-/dev/fb0 c 600 0 0 29 0 - - -
-/dev/hda b 660 0 6 3 0 - - -
-/dev/hda b 660 0 6 3 1 1 1 19
-/dev/kmem c 640 0 15 1 2 - - -
-/dev/mem c 640 0 15 1 1 - - -
-/dev/null c 666 0 0 1 3 - - -
-/dev/ram b 640 0 0 1 0 0 1 4
-/dev/tty c 662 0 5 5 0 - - -
-/dev/tty c 666 0 5 4 0 0 1 9
-/dev/ttyS c 640 0 5 4 64 0 1 1
-/dev/ttySA c 640 0 5 204 5 0 1 1
-/dev/zero c 644 0 0 1 5 - - -
-/dev/mtd c 660 0 6 90 0 0 2 8
-/dev/mtdblock b 640 0 0 31 0 0 1 8
-/dev/console c 662 0 5 5 1 - - -
-/dev/random c 644 0 0 1 8 - - -
-/dev/urandom c 644 0 0 1 9 - - -
-/dev/ptmx c 644 0 0 5 2 - - -
-
-# mmc numbers are assigned dynamicly so if you have other dynamic assigned block devices it may be wrong
-/dev/mmcblk0 b 660 0 6 254 0 - - -
-/dev/mmcblk0p b 660 0 6 254 1 1 1 7
-/dev/event0 c 660 0 0 13 64 - - -
diff --git a/recipes/kexecboot/initramfs-kexecboot-image.bb b/recipes/kexecboot/initramfs-kexecboot-image.bb
index 285640dcf5..c251aa9cf2 100644
--- a/recipes/kexecboot/initramfs-kexecboot-image.bb
+++ b/recipes/kexecboot/initramfs-kexecboot-image.bb
@@ -1,16 +1,11 @@
# Initramfs image providing kexecboot
# a linux as bootloader implementation
-PR = "r2"
+PR = "r3"
ONLINE_PACKAGE_MANAGEMENT = "none"
IMAGE_FSTYPES = "cpio.gz cpio.lzma"
DEPENDS = "lzma-native"
-# Deprecated: device nodes are populated by kexecboot now
-# These devices need mmcblk* to be 254 instead of 179
-IMAGE_DEVICE_TABLES_hx4700 = "device_table-oldmmc.txt"
-IMAGE_DEVICE_TABLES_h2200 = "device_table-oldmmc.txt"
-
export IMAGE_BASENAME = "initramfs-kexecboot-image"
# avoid circular dependencies
@@ -23,5 +18,7 @@ IMAGE_LOGIN_MANAGER = ""
IMAGE_INIT_MANAGER = ""
IMAGE_INITSCRIPTS = ""
IMAGE_DEV_MANAGER = ""
+
FEED_DEPLOYDIR_BASE_URI = ""
+
inherit image
diff --git a/recipes/kexecboot/kexecboot.inc b/recipes/kexecboot/kexecboot.inc
index 5db3414821..3f37f9e720 100644
--- a/recipes/kexecboot/kexecboot.inc
+++ b/recipes/kexecboot/kexecboot.inc
@@ -9,12 +9,24 @@ inherit autotools
# ./make-image-header.sh <file>.png HAND
SRC_URI += "file://logo-img.h \
- file://logo.png \
- "
+ file://logo.png \
+ "
export CC=${TARGET_PREFIX}klcc
-# for output on serial console: --enable-debug
+# Defaults as in ver 0.5+0.6b
+# --with_static_linking=no
+# --with_fbmenu=yes
+# --with_cfgfiles=yes
+# --with_icons=yes
+# --with_zaurus=no
+# --with_zimage=yes
+# --with_uimage=no
+# --with_machine_kernel=no
+# --enable_devices_recreating="yes"
+# --enable_debug="no"
+# --enable_host_debug="no"
+
EXTRA_OECONF_akita = "--with-zaurus"
EXTRA_OECONF_c7x0 = "--with-zaurus"
EXTRA_OECONF_spitz = "--with-zaurus"
@@ -24,20 +36,20 @@ EXTRA_OECONF_tosa = "--with-zaurus"
EXTRA_OECONF_omap3 = "--with-uimage"
do_configure_prepend () {
- install -m 0644 ${WORKDIR}/logo-img.h ${S}/res/
- install -m 0644 ${WORKDIR}/logo.png ${S}/res/
+ install -m 0644 ${WORKDIR}/logo-img.h ${S}/res/
+ install -m 0644 ${WORKDIR}/logo.png ${S}/res/
}
do_install () {
- install -d ${D}${bindir}
- install -m 0755 kexecboot ${D}${bindir}/
+ install -d ${D}${bindir}
+ install -m 0755 kexecboot ${D}${bindir}/
- install -d ${D}/proc
- install -d ${D}/mnt
+ install -d ${D}/proc
+ install -d ${D}/mnt
}
FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt"
pkg_postinst_${PN} () {
- ln -sf ${bindir}/kexecboot $D/init
+ ln -sf ${bindir}/kexecboot $D/init
}