aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Ospite <ospite@studenti.unina.it>2010-04-22 17:00:30 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-22 17:19:48 +0200
commit539d5a80beb6b5892c83ba6b8d27d622c3cdb114 (patch)
tree3e7a7d63475aef9c4601c4e3ce1c98f9f76431a6
parent770632552a15954d1873c7a93adc724d4956bea9 (diff)
downloadopenembedded-539d5a80beb6b5892c83ba6b8d27d622c3cdb114.tar.gz
python-2.6.4: make Modules/_ctypes/libffi configure
This fixes configure issues with recent autoconf, e.g: autoreconf: Entering directory `Modules/_ctypes/libffi' autoreconf: configure.ac: not using Gettext autoreconf: running: aclocal --force configure.ac:26: error: m4_copy: won't overwrite defined macro: \ _AC_ARG_VAR_PRECIOUS configure.ac:26: the top level It also adjustes Makefile.am to take into account the fact that python ships incomplete source from libffi. Signed-off-by: Antonio Ospite <ospite@studenti.unina.it> Acked-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/python/python-2.6.4/06-ctypes-libffi-fix-configure.patch51
-rw-r--r--recipes/python/python-native_2.6.4.bb3
-rw-r--r--recipes/python/python_2.6.4.bb3
3 files changed, 55 insertions, 2 deletions
diff --git a/recipes/python/python-2.6.4/06-ctypes-libffi-fix-configure.patch b/recipes/python/python-2.6.4/06-ctypes-libffi-fix-configure.patch
new file mode 100644
index 0000000000..3773791385
--- /dev/null
+++ b/recipes/python/python-2.6.4/06-ctypes-libffi-fix-configure.patch
@@ -0,0 +1,51 @@
+This fixes configure issues with recent autoconf, e.g:
+ autoreconf: Entering directory `Modules/_ctypes/libffi'
+ autoreconf: configure.ac: not using Gettext
+ autoreconf: running: aclocal --force
+ configure.ac:26: error: m4_copy: won't overwrite defined macro: _AC_ARG_VAR_PRECIOUS
+ configure.ac:26: the top level
+
+The problem is still present in python-2.6.5 but fixed in python-svn.
+
+diff -pruN Python-2.6.4.orig//Modules/_ctypes/libffi/configure.ac Python-2.6.4/Modules/_ctypes/libffi/configure.ac
+--- Python-2.6.4.orig//Modules/_ctypes/libffi/configure.ac 2009-04-28 22:01:18.000000000 +0200
++++ Python-2.6.4/Modules/_ctypes/libffi/configure.ac 2010-04-20 22:46:02.000000000 +0200
+@@ -23,6 +23,7 @@ AM_INIT_AUTOMAKE
+ m4_rename([_AC_ARG_VAR_PRECIOUS],[real_PRECIOUS])
+ m4_define([_AC_ARG_VAR_PRECIOUS],[])
+ AC_PROG_CC
++m4_undefine([_AC_ARG_VAR_PRECIOUS])
+ m4_rename([real_PRECIOUS],[_AC_ARG_VAR_PRECIOUS])
+
+ AC_SUBST(CFLAGS)
+@@ -366,7 +367,7 @@ test -d src/$TARGETDIR || mkdir src/$TAR
+
+ AC_CONFIG_LINKS(include/ffitarget.h:src/$TARGETDIR/ffitarget.h)
+
+-AC_CONFIG_FILES(include/ffi.h)
++AC_CONFIG_FILES(include/ffi.h include/Makefile Makefile)
+
+ AC_CONFIG_LINKS(include/ffi_common.h:include/ffi_common.h)
+
+diff -pruN Python-2.6.4.orig//Modules/_ctypes/libffi/Makefile.am Python-2.6.4/Modules/_ctypes/libffi/Makefile.am
+--- Python-2.6.4.orig//Modules/_ctypes/libffi/Makefile.am 2008-03-04 21:09:11.000000000 +0100
++++ Python-2.6.4/Modules/_ctypes/libffi/Makefile.am 2010-04-20 22:54:03.000000000 +0200
+@@ -2,7 +2,7 @@
+
+ AUTOMAKE_OPTIONS = foreign subdir-objects
+
+-SUBDIRS = include testsuite man
++SUBDIRS = include
+
+ EXTRA_DIST = LICENSE ChangeLog.v1 ChangeLog.libgcj configure.host \
+ src/alpha/ffi.c src/alpha/osf.S src/alpha/ffitarget.h \
+@@ -32,8 +32,6 @@ EXTRA_DIST = LICENSE ChangeLog.v1 Change
+ src/frv/ffi.c src/frv/eabi.S src/frv/ffitarget.h src/dlmalloc.c \
+ libtool-version ChangeLog.libffi
+
+-info_TEXINFOS = doc/libffi.texi
+-
+ ## ################################################################
+
+ ##
+
diff --git a/recipes/python/python-native_2.6.4.bb b/recipes/python/python-native_2.6.4.bb
index ca65057395..ffa9a45a91 100644
--- a/recipes/python/python-native_2.6.4.bb
+++ b/recipes/python/python-native_2.6.4.bb
@@ -1,12 +1,13 @@
require python.inc
DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native"
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
file://00-fix-bindir-libdir-for-cross.patch;patch=1 \
file://04-default-is-optimized.patch;patch=1 \
file://05-enable-ctypes-cross-build.patch;patch=1 \
+ file://06-ctypes-libffi-fix-configure.patch;patch=1 \
file://10-distutils-fix-swig-parameter.patch;patch=1 \
file://11-distutils-never-modify-shebang-line.patch;patch=1 \
file://12-distutils-prefix-is-inside-staging-area.patch;patch=1 \
diff --git a/recipes/python/python_2.6.4.bb b/recipes/python/python_2.6.4.bb
index 6d93c2cb09..17891e926b 100644
--- a/recipes/python/python_2.6.4.bb
+++ b/recipes/python/python_2.6.4.bb
@@ -3,7 +3,7 @@ DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl zlib\
${@base_contains('DISTRO_FEATURES', 'tk', 'tk', '', d)}"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
# set to .0 on every increase of INC_PR
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
@@ -13,6 +13,7 @@ SRC_URI = "\
file://03-fix-tkinter-detection.patch;patch=1 \
file://04-default-is-optimized.patch;patch=1 \
file://05-enable-ctypes-cross-build.patch;patch=1 \
+ file://06-ctypes-libffi-fix-configure.patch;patch=1 \
file://99-ignore-optimization-flag.patch;patch=1 \
\
# not yet pushed forward