aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2010-06-04 14:02:59 +0100
committerPhil Blundell <philb@gnu.org>2010-06-04 14:02:59 +0100
commit1d84ab01cc0d66368e07564e8498bcdd73e35018 (patch)
treec2cfd8a46e1eae2d41b930f89e9facafe1b228d0
parentc235146da8799defb436c414ee6f11b4b2a0e1c3 (diff)
downloadopenembedded-1d84ab01cc0d66368e07564e8498bcdd73e35018.tar.gz
thttpd: fix a compilation failure
-rw-r--r--recipes/thttpd/files/htpasswd_getline.diff20
-rw-r--r--recipes/thttpd/thttpd_2.25b.bb5
2 files changed, 23 insertions, 2 deletions
diff --git a/recipes/thttpd/files/htpasswd_getline.diff b/recipes/thttpd/files/htpasswd_getline.diff
new file mode 100644
index 0000000000..82b12e28cb
--- /dev/null
+++ b/recipes/thttpd/files/htpasswd_getline.diff
@@ -0,0 +1,20 @@
+--- thttpd-2.25b/extras/htpasswd.c.old 2010-04-28 17:23:40.000000000 +0100
++++ thttpd-2.25b/extras/htpasswd.c 2010-04-28 17:24:00.000000000 +0100
+@@ -49,7 +49,7 @@
+ while((line[y++] = line[x++]));
+ }
+
+-static int getline(char *s, int n, FILE *f) {
++static int ht_getline(char *s, int n, FILE *f) {
+ register int i=0;
+
+ while(1) {
+@@ -189,7 +189,7 @@
+ strcpy(user,argv[2]);
+
+ found = 0;
+- while(!(getline(line,MAX_STRING_LEN,f))) {
++ while(!(ht_getline(line,MAX_STRING_LEN,f))) {
+ if(found || (line[0] == '#') || (!line[0])) {
+ putline(tfp,line);
+ continue;
diff --git a/recipes/thttpd/thttpd_2.25b.bb b/recipes/thttpd/thttpd_2.25b.bb
index 8e9011c17d..85c7f70a6a 100644
--- a/recipes/thttpd/thttpd_2.25b.bb
+++ b/recipes/thttpd/thttpd_2.25b.bb
@@ -1,13 +1,14 @@
DESCRIPTION = "A simple, small, portable, fast, and secure HTTP server."
LICENSE = "BSD"
HOMEPAGE = "http://www.acme.com/software/thttpd/"
-PR ="r7"
+PR ="r8"
SRC_URI = "http://www.acme.com/software/thttpd/thttpd-2.25b.tar.gz \
file://install.patch \
file://acinclude.m4 \
file://init \
- file://htpasswd_shared.diff"
+ file://htpasswd_shared.diff \
+ file://htpasswd_getline.diff"
S = "${WORKDIR}/thttpd-${PV}"
PARALLEL_MAKE = ""