aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-02-20 20:49:43 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-02-20 21:01:22 +0100
commit1516588acd3c4b4dd4add71d06ab8ce0d1bafa02 (patch)
tree505afcf7bdc0915d7f9a6562d0690143456a88a0
parentee97ccce95a61f20f78fb5e133133b7d9f6ed3de (diff)
downloadopenembedded-1516588acd3c4b4dd4add71d06ab8ce0d1bafa02.tar.gz
linux-2.6.34: add unwinding to om-gta02's defconfig
Adding unwinding remove CONFIG_FRAME_POINTER while preserving its debug functionalities at the cost of a bigger image (that we mitigate by using LZMA compression instead of gzip) Pratically speaking that should result in speed improvements: Speed seem to be faster but was not tested scientifically. Here's the unwinding help: This option enables stack unwinding support in the kernel using the information automatically generated by the compiler. The resulting kernel image is slightly bigger but the performance is not affected. Currently, this feature only works with EABI compilers. If unsure say Y. And the frame pointer help: If you say N here, the resulting kernel will be slightly smaller and faster. However, if neither FRAME_POINTER nor ARM_UNWIND are enabled, when a problem occurs with the kernel, the information that is reported is severely limited. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org> Acked-by: Klaus Kurzmann <mok@fluxnetz.de>
-rw-r--r--recipes/linux/linux-2.6.34/om-gta02/defconfig9
-rw-r--r--recipes/linux/linux-openmoko_2.6.34.bb2
2 files changed, 5 insertions, 6 deletions
diff --git a/recipes/linux/linux-2.6.34/om-gta02/defconfig b/recipes/linux/linux-2.6.34/om-gta02/defconfig
index 1a89076a23..4dce7afe43 100644
--- a/recipes/linux/linux-2.6.34/om-gta02/defconfig
+++ b/recipes/linux/linux-2.6.34/om-gta02/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.34.8
-# Fri Jan 14 10:01:21 2011
+# Sun Feb 20 14:21:33 2011
#
CONFIG_ARM=y
CONFIG_HAVE_PWM=y
@@ -38,9 +38,9 @@ CONFIG_LOCALVERSION=""
CONFIG_HAVE_KERNEL_GZIP=y
CONFIG_HAVE_KERNEL_LZMA=y
CONFIG_HAVE_KERNEL_LZO=y
-CONFIG_KERNEL_GZIP=y
+# CONFIG_KERNEL_GZIP is not set
# CONFIG_KERNEL_BZIP2 is not set
-# CONFIG_KERNEL_LZMA is not set
+CONFIG_KERNEL_LZMA=y
# CONFIG_KERNEL_LZO is not set
CONFIG_SWAP=y
CONFIG_SYSVIPC=y
@@ -2094,7 +2094,6 @@ CONFIG_STRIP_ASM_SYMS=y
# CONFIG_DEBUG_KERNEL is not set
CONFIG_DEBUG_BUGVERBOSE=y
# CONFIG_DEBUG_MEMORY_INIT is not set
-CONFIG_FRAME_POINTER=y
# CONFIG_RCU_CPU_STALL_DETECTOR is not set
# CONFIG_LATENCYTOP is not set
# CONFIG_SYSCTL_SYSCALL_CHECK is not set
@@ -2103,7 +2102,7 @@ CONFIG_TRACING_SUPPORT=y
# CONFIG_FTRACE is not set
# CONFIG_SAMPLES is not set
CONFIG_HAVE_ARCH_KGDB=y
-# CONFIG_ARM_UNWIND is not set
+CONFIG_ARM_UNWIND=y
# CONFIG_DEBUG_USER is not set
# CONFIG_OC_ETM is not set
CONFIG_DEBUG_S3C_UART=2
diff --git a/recipes/linux/linux-openmoko_2.6.34.bb b/recipes/linux/linux-openmoko_2.6.34.bb
index 078980386c..9da7bf8500 100644
--- a/recipes/linux/linux-openmoko_2.6.34.bb
+++ b/recipes/linux/linux-openmoko_2.6.34.bb
@@ -2,5 +2,5 @@ require linux_${PV}.bb
require linux-openmoko.inc
# just for upgrade path in 2.6.34
KERNEL_RELEASE = "2.6.34.8"
-OM-PR = "16"
+OM-PR = "17"
PKGV = "${KERNEL_RELEASE}-oe${OM-PR}"