summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-01-19 13:31:42 +0100
committerKoen Kooi <koen@openembedded.org>2011-01-19 13:31:42 +0100
commit9b1bfb911b7e5681ffa8a0a646d76e995d090713 (patch)
tree0a5ee83e9b638ac9789791a37771d6b45da7f146
parentbc3d41b3632b828a500150e13c8280df2e331b15 (diff)
downloadopenembedded-9b1bfb911b7e5681ffa8a0a646d76e995d090713.tar.gz
linux-omap 2.6.37: fix SysRq on ttyOx
Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/linux/linux-omap-2.6.37/new/0001-OMAP-Enable-Magic-SysRq-on-serial-console-ttyOx.patch35
-rw-r--r--recipes/linux/linux-omap_2.6.37.bb2
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes/linux/linux-omap-2.6.37/new/0001-OMAP-Enable-Magic-SysRq-on-serial-console-ttyOx.patch b/recipes/linux/linux-omap-2.6.37/new/0001-OMAP-Enable-Magic-SysRq-on-serial-console-ttyOx.patch
new file mode 100644
index 0000000000..e157d3601c
--- /dev/null
+++ b/recipes/linux/linux-omap-2.6.37/new/0001-OMAP-Enable-Magic-SysRq-on-serial-console-ttyOx.patch
@@ -0,0 +1,35 @@
+From a43b9359708691eb3aec983da36461720fb4a556 Mon Sep 17 00:00:00 2001
+From: Thomas Weber <weber@corscience.de>
+Date: Wed, 19 Jan 2011 09:41:01 +0100
+Subject: [PATCH] OMAP: Enable Magic SysRq on serial console ttyOx
+
+Magic SysRq key is not working for OMAP on new serial
+console ttyOx because SUPPORT_SYSRQ is not defined
+for omap-serial.
+
+This patch defines SUPPORT_SYSRQ in omap-serial and
+enables handling of Magic SysRq character.
+
+Signed-off-by: Thomas Weber <weber@corscience.de>
+---
+ drivers/serial/omap-serial.c | 4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+diff --git a/drivers/serial/omap-serial.c b/drivers/serial/omap-serial.c
+index 1201eff..907be9b 100644
+--- a/drivers/serial/omap-serial.c
++++ b/drivers/serial/omap-serial.c
+@@ -20,6 +20,10 @@
+ * this driver as required for the omap-platform.
+ */
+
++#if defined(CONFIG_SERIAL_OMAP_CONSOLE) && defined(CONFIG_MAGIC_SYSRQ)
++#define SUPPORT_SYSRQ
++#endif
++
+ #include <linux/module.h>
+ #include <linux/init.h>
+ #include <linux/console.h>
+--
+1.6.6.1
+
diff --git a/recipes/linux/linux-omap_2.6.37.bb b/recipes/linux/linux-omap_2.6.37.bb
index 6babf340fa..c6a62b7c18 100644
--- a/recipes/linux/linux-omap_2.6.37.bb
+++ b/recipes/linux/linux-omap_2.6.37.bb
@@ -131,6 +131,8 @@ SRC_URI_append = " \
file://dvfs/0018-omap3-4-opp-make-omapx_opp_init-non-static.patch \
file://dvfs/0019-OMAP3-beagle-xm-enable-upto-1GHz-OPP.patch \
file://dvfs/0020-omap3-Add-basic-support-for-720MHz-part.patch \
+ \
+ file://new/0001-OMAP-Enable-Magic-SysRq-on-serial-console-ttyOx.patch \
"
SRC_URI_append_usrp-e1xx = "\