summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniele Ricci <daniele.athome@gmail.com>2010-12-21 18:32:06 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-12-21 21:46:28 +0100
commit4bccf3c2dfdb2e0affae98e4be83836dfa554d5b (patch)
tree6bb8b44e1f32d6e8d62332ed62a0a993d71c29c0
parent6a6b70744cbfa008043d11cbc93af950f38adc77 (diff)
downloadopenembedded-4bccf3c2dfdb2e0affae98e4be83836dfa554d5b.tar.gz
mokosuite2: removed phone and panel from appbunch in favour of dedicated applications
* mokosuite2 SRCREV bump * mokohome SRCREV BUMP * libmokosuite2 SRCREV BUMP * mokopanel: new recipe * mokophone: new recipe Signed-off-by: Daniele Ricci <daniele.athome@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/mokosuite2/libmokosuite_git.bb4
-rw-r--r--recipes/mokosuite2/mokohome_git.bb2
-rw-r--r--recipes/mokosuite2/mokopanel_git.bb23
-rw-r--r--recipes/mokosuite2/mokophone_git.bb23
-rw-r--r--recipes/mokosuite2/mokosuite2_git.bb2
5 files changed, 50 insertions, 4 deletions
diff --git a/recipes/mokosuite2/libmokosuite_git.bb b/recipes/mokosuite2/libmokosuite_git.bb
index 586809b05e..72b407012c 100644
--- a/recipes/mokosuite2/libmokosuite_git.bb
+++ b/recipes/mokosuite2/libmokosuite_git.bb
@@ -2,12 +2,12 @@ DESCRIPTION = "Desktop environment and phone stack GUI for SHR - core library"
HOMEPAGE = "http://gitorious.org/mokosuite2"
AUTHOR = "Daniele Ricci"
LICENSE = "GPLv3"
-DEPENDS = "elementary libfreesmartphone-glib libphone-utils eggdbus glib-2.0 dbus-glib alsa-lib db sqlite3 vala-native edje-native"
+DEPENDS = "elementary libfreesmartphone-glib libphone-utils eggdbus glib-2.0 dbus-glib alsa-lib db sqlite3 vala-native edje-native libnotify"
SECTION = "misc/utils"
PV = "1.0.99+gitr${SRCPV}"
PR = "r1"
-SRCREV = "d8e5a780d93ba2c22514502ad9cca0ba66ff7b9d"
+SRCREV = "5f53727c1ec3539464a2c80f18acdbc8a7795678"
SRC_URI = "git://gitorious.org/mokosuite2/libmokosuite.git;protocol=git"
S = "${WORKDIR}/git"
diff --git a/recipes/mokosuite2/mokohome_git.bb b/recipes/mokosuite2/mokohome_git.bb
index 33b74bf9b7..2b077d3887 100644
--- a/recipes/mokosuite2/mokohome_git.bb
+++ b/recipes/mokosuite2/mokohome_git.bb
@@ -6,7 +6,7 @@ DEPENDS = "libmokosuite edje-native"
SECTION = "misc/utils"
PV = "1.0.99+gitr${SRCPV}"
-SRCREV = "c7126d6a754b58add0f76d1994a92e2be60705df"
+SRCREV = "21b6a4d72236829acdd6ef9525d107227c6cab1b"
SRC_URI = "git://gitorious.org/mokosuite2/mokohome.git;protocol=git"
S = "${WORKDIR}/git"
diff --git a/recipes/mokosuite2/mokopanel_git.bb b/recipes/mokosuite2/mokopanel_git.bb
new file mode 100644
index 0000000000..4ec71c5050
--- /dev/null
+++ b/recipes/mokosuite2/mokopanel_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Desktop environment and phone stack GUI for SHR - dock panel and idle screen"
+HOMEPAGE = "http://gitorious.org/mokosuite2"
+AUTHOR = "Daniele Ricci"
+LICENSE = "GPLv3"
+DEPENDS = "libmokosuite libfreesmartphone-glib glib-2.0 dbus-glib elementary vala-native edje-native"
+SECTION = "misc/utils"
+
+PV = "1.0.99+gitr${SRCPV}"
+SRCREV = "a7140f6aba2de7d7ec69349c89b647c391dcc832"
+
+SRC_URI = "git://gitorious.org/mokosuite2/mokopanel.git;protocol=git"
+S = "${WORKDIR}/git"
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = " --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc --enable-debug"
+FILES_${PN} += "${datadir}/mokosuite/panel"
+
+inherit autotools
+
+do_install_append() {
+ ln -s themes/gry.edj ${D}${datadir}/mokosuite/panel/theme.edj
+}
diff --git a/recipes/mokosuite2/mokophone_git.bb b/recipes/mokosuite2/mokophone_git.bb
new file mode 100644
index 0000000000..b80a62631b
--- /dev/null
+++ b/recipes/mokosuite2/mokophone_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Desktop environment and phone stack GUI for SHR - phone application"
+HOMEPAGE = "http://gitorious.org/mokosuite2"
+AUTHOR = "Daniele Ricci"
+LICENSE = "GPLv3"
+DEPENDS = "libmokosuite libfreesmartphone-glib libphone-utils alsa-lib glib-2.0 dbus-glib elementary vala-native edje-native"
+SECTION = "misc/utils"
+
+PV = "1.0.99+gitr${SRCPV}"
+SRCREV = "ff9029c6ba64e90aa26cb70eedfc63071e095d78"
+
+SRC_URI = "git://gitorious.org/mokosuite2/mokophone.git;protocol=git"
+S = "${WORKDIR}/git"
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = " --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc --enable-debug"
+FILES_${PN} += "${datadir}/mokosuite/phone"
+
+inherit autotools
+
+do_install_append() {
+ ln -s themes/gry.edj ${D}${datadir}/mokosuite/phone/theme.edj
+}
diff --git a/recipes/mokosuite2/mokosuite2_git.bb b/recipes/mokosuite2/mokosuite2_git.bb
index 7ac9b7aae7..698b658085 100644
--- a/recipes/mokosuite2/mokosuite2_git.bb
+++ b/recipes/mokosuite2/mokosuite2_git.bb
@@ -7,7 +7,7 @@ SECTION = "misc/utils"
PV = "1.0.99+gitr${SRCPV}"
PR = "r2"
-SRCREV = "c2fbbf1de2694d6fb1031efb1a1c9335bd33e8e3"
+SRCREV = "da6981b5c9426f68d616bebb9a62b8337a21ad60"
SRC_URI = "git://gitorious.org/mokosuite2/appbunch.git;protocol=git"
S = "${WORKDIR}/git"