aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-06-02 13:48:31 +0200
committerSimon Busch <morphis@gravedo.de>2011-06-22 18:54:43 +0200
commitb7915f5af43dd9a03330e36fa8983fb2a934f41e (patch)
tree2a0e785aaf7f4372456f4f8722262ac9a7049ecb
parentd93a3686a2401c5155367940296c7ed13d13b055 (diff)
downloadopenembedded-b7915f5af43dd9a03330e36fa8983fb2a934f41e.tar.gz
fsousaged: fix configuration for palmpre with aurora distro and bump PR
Within aurora we use the shadow resource feature of fsousaged, but other distro can't use them and as FSO configs are only machine specific we need to fix it here. Signed-off-by: Simon Busch <morphis@gravedo.de>
-rw-r--r--recipes/freesmartphone/fsousaged_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/freesmartphone/fsousaged_git.bb b/recipes/freesmartphone/fsousaged_git.bb
index d6a2adf2a4..ae402ae193 100644
--- a/recipes/freesmartphone/fsousaged_git.bb
+++ b/recipes/freesmartphone/fsousaged_git.bb
@@ -3,4 +3,9 @@ inherit fso-plugin
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
PV = "0.9.5+gitr${SRCPV}"
PE = "1"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
+
+do_configure_append_aurora() {
+ # Fix configuration for aurora distribution as other distros get's broken by this
+ sed -i -e 's/^enable_shadow_resources.*$/enable_shadow_resources = 1/g' ${S}/conf/palm_pre/fsousaged.conf
+}