aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-07-04 17:04:32 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-07-05 17:49:53 +0200
commit301be5cccdc0d997e60813e58d7efb0df34e5fa3 (patch)
tree50b8dc6d94021d3dd30f0da5a77fa454e078f7bc
parent2b7ffeb0ffc0191b5cf213dcd0031ba9fa6506ba (diff)
downloadopenembedded-301be5cccdc0d997e60813e58d7efb0df34e5fa3.tar.gz
tor: quiet the init script(else it prints to the console)
Without that patch the tor init script print to the console, even when the init script has finished to run. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
-rwxr-xr-xrecipes/tor/files/tor.init8
-rw-r--r--recipes/tor/tor_0.1.1.26.bb2
2 files changed, 6 insertions, 4 deletions
diff --git a/recipes/tor/files/tor.init b/recipes/tor/files/tor.init
index e421347440..0e9a5abe39 100755
--- a/recipes/tor/files/tor.init
+++ b/recipes/tor/files/tor.init
@@ -11,20 +11,20 @@ test -f /etc/tor/tor-tsocks.conf || exit 0
case "$1" in
start)
echo -n "Starting tor daemon"
- start-stop-daemon --start --quiet --exec /usr/bin/tor &
+ start-stop-daemon --start --quiet --exec /usr/bin/tor > /dev/null &
echo "."
;;
stop)
echo -n "Stopping tor daemon"
- start-stop-daemon --stop --quiet --exec /usr/bin/tor &
+ start-stop-daemon --stop --quiet --exec /usr/bin/tor > /dev/null &
echo "."
;;
restart)
echo -n "Stopping tor daemon"
- start-stop-daemon --stop --quiet --exec /usr/bin/tor &
+ start-stop-daemon --stop --quiet --exec /usr/bin/tor > /dev/null &
sleep 1
echo -n "Starting tor daemon"
- start-stop-daemon --start --quiet --exec /usr/bin/tor &
+ start-stop-daemon --start --quiet --exec /usr/bin/tor > /dev/null &
echo "."
;;
start_socats)
diff --git a/recipes/tor/tor_0.1.1.26.bb b/recipes/tor/tor_0.1.1.26.bb
index 1045c0b6b6..a39725d043 100644
--- a/recipes/tor/tor_0.1.1.26.bb
+++ b/recipes/tor/tor_0.1.1.26.bb
@@ -6,6 +6,8 @@ PRIORITY = "optional"
LICENSE = "BSD"
DEPENDS = "libevent openssl zlib"
+PR = "r1"
+
SRC_URI = "http://tor.eff.org/dist/${P}.tar.gz \
file://configure.patch \
file://make.patch \