aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-02-13 07:52:41 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2011-05-04 10:41:39 +0200
commit8cd4cf2430251f31bb25a6cbb876e6bb656257b3 (patch)
tree5771fd404e3abac6288ea1b6471c5243c6f2f760
parentfe99bebea1a64d61eaf4181146c7ad067a4be9c6 (diff)
downloadopenembedded-8cd4cf2430251f31bb25a6cbb876e6bb656257b3.tar.gz
spojegui: fix build without ipkg-build and fix QA issues
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/openmoko-3rdparty/spojegui_svn.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes/openmoko-3rdparty/spojegui_svn.bb b/recipes/openmoko-3rdparty/spojegui_svn.bb
index a0700e0112..8e94d7b042 100644
--- a/recipes/openmoko-3rdparty/spojegui_svn.bb
+++ b/recipes/openmoko-3rdparty/spojegui_svn.bb
@@ -8,7 +8,7 @@ RDEPENDS_${PN} = "python-core python-elementary python-sqlite3 python-netclient"
SRCREV = "64"
PV = "0.4.2+svnr${SRCPV}"
-PR = "r1"
+PR = "r2"
S = "${WORKDIR}/build"
@@ -16,6 +16,12 @@ PACKAGE_ARCH = "all"
SRC_URI = "svn://xeres.cz/spoje;module=build"
+# override base_do_compile with own as included Makefile calls ipkg-build and it's not usefull to us at all
+do_compile() {
+ # fix QA issue
+ sed -i '/^Encoding/d;/^Version/d;s/Categories=Application;/Categories=Utility;/g' ${S}/data/spoje.desktop
+}
+
do_install() {
install -d "${D}/${bindir}"
install -m 0755 "${S}/src/spoje.py" "${D}/${bindir}"