aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2007-01-15 08:44:00 +0000
committerJustin Patrin <papercrane@gmail.com>2007-01-15 08:44:00 +0000
commit4982ecb99363d3f06453f33c9e62cbcd69efb0fd (patch)
treedbe35718bd0e1c1a04015e8a5c625406c5a78fcc
parent078057086811211ac53db2d490f8576b4a239823 (diff)
downloadopenembedded-4982ecb99363d3f06453f33c9e62cbcd69efb0fd.tar.gz
libxml2: add -native to allow builds to finish (copied from .dev)
-rw-r--r--packages/libxml/libxml2-native_2.6.9.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/libxml/libxml2-native_2.6.9.bb b/packages/libxml/libxml2-native_2.6.9.bb
new file mode 100644
index 0000000000..df3ab07460
--- /dev/null
+++ b/packages/libxml/libxml2-native_2.6.9.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "GNOME XML library"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/old/libxml2-${PV}.tar.gz"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+S = "${WORKDIR}/libxml2-${PV}"
+
+inherit autotools native pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --without-c14n"
+
+headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
+
+do_stage () {
+ oe_runmake install
+}