aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-05-18 23:10:17 +0200
committerSimon Busch <morphis@gravedo.de>2011-05-19 14:12:02 +0200
commitb6b191364ee3fd32bfd1d0e9e273df7c39e7b10b (patch)
tree51659e89842de3ec09f33ec0842c98e7562c040b
parentfcc88afa4f342f6cd1170a2630f83b58828b88d6 (diff)
downloadopenembedded-b6b191364ee3fd32bfd1d0e9e273df7c39e7b10b.tar.gz
aurora: rework init script and bump PR
Signed-off-by: Simon Busch <morphis@gravedo.de>
-rw-r--r--recipes/freesmartphone/aurora/aurora-daemon43
-rw-r--r--recipes/freesmartphone/aurora_git.bb8
2 files changed, 44 insertions, 7 deletions
diff --git a/recipes/freesmartphone/aurora/aurora-daemon b/recipes/freesmartphone/aurora/aurora-daemon
index 73beb1b5fb..3bb8fae7dd 100644
--- a/recipes/freesmartphone/aurora/aurora-daemon
+++ b/recipes/freesmartphone/aurora/aurora-daemon
@@ -1,3 +1,40 @@
-#!/bin/sh
-export QWS_MOUSE_PROTO="LinuxInput:/dev/input/event6"
-aurora -qws > /tmp/aurora.log 2>&1 &
+#! /bin/sh
+#
+# aurora-daemon -- This shell script starts and stops the FSO feature phone client
+#
+# chkconfig: 345 90 10
+# description: aurora is the feature phone client for the FSO framework
+# processname: aurora
+
+PATH=/bin:/usr/bin:/sbin:/usr/sbin
+NAME=aurora
+
+[ -f /etc/default/rcS ] && . /etc/default/rcS
+
+case "$1" in
+ start)
+ echo -n "Starting aurora-daemon: "
+ start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/${NAME} -- -qws
+ if [ $? = 0 ]; then
+ echo "(ok)"
+ else
+ echo "(failed)"
+ fi
+ ;;
+ stop)
+ echo -n "Stopping aurora-daemon: "
+ start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
+ rm -f /var/run/${NAME}.pid
+ echo "(done)"
+ ;;
+ restart|force-reload)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "Usage: /etc/init.d/aurora-daemon {start|stop|restart|force-reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/freesmartphone/aurora_git.bb b/recipes/freesmartphone/aurora_git.bb
index 0c24c33c8b..f1839c856e 100644
--- a/recipes/freesmartphone/aurora_git.bb
+++ b/recipes/freesmartphone/aurora_git.bb
@@ -6,7 +6,7 @@ SECTION = "fso"
LICENSE = "GPLv2"
SRCREV = "6db9e04728bd0434e6b79939ee18be43017afeef"
PV = "0.1.0+gitr${SRCPV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "\
${FREESMARTPHONE_GIT}/aurora.git;protocol=git;branch=master \
@@ -26,11 +26,11 @@ RDEPENDS_${PN} = "\
inherit autotools python-dir update-rc.d
INITSCRIPT_NAME = "aurora-daemon"
-INITSCRIPT_PARAMS = "defaults 40"
+INITSCRIPT_PARAMS = "defaults 90"
do_install_append() {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/
}
PACKAGES = "${PN}"