aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2012-02-18 21:00:38 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-02-21 12:33:25 +0100
commit91e7878c3424aa67318d056d4194f85fc224f600 (patch)
treed9c1cbb9a7cafb6a47b0a9397c32a47af2a1b8d7
parent37bb81577243b4de56d67452b90696020c79ee23 (diff)
downloadopenembedded-91e7878c3424aa67318d056d4194f85fc224f600.tar.gz
openjdk-6-common.inc: fix hardcoded path for allowing to build with linux 3.x
-rw-r--r--recipes/openjdk/openjdk-6-common.inc7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes/openjdk/openjdk-6-common.inc b/recipes/openjdk/openjdk-6-common.inc
index f00a6babe2..ee3db29d7c 100644
--- a/recipes/openjdk/openjdk-6-common.inc
+++ b/recipes/openjdk/openjdk-6-common.inc
@@ -212,6 +212,13 @@ do_configure_prepend() {
do_configure_append() {
oe_runmake patch-ecj
+
+ for F in ${WORKDIR}/openjdk-src-dir/hotspot/make/linux/Makefile ${B}/openjdk-ecj/hotspot/make/linux/Makefile ${B}/openjdk/hotspot/make/linux/Makefile ;
+ do
+ sed -i \
+ -e"s|SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 2.7%|SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3%|" \
+ $F
+ done
}
# Work around broken variable quoting in oe-stable 2009 and provide the variable