aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2012-02-17 18:47:31 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-02-21 12:32:48 +0100
commit77986e980258cd6b976e56fa0239ae0a4fdc01f9 (patch)
tree595dce207e2c74483b6ccb495e8df42118c3f41f
parentdee11af6bc099c2a5ebe601752a88df65c2640da (diff)
downloadopenembedded-77986e980258cd6b976e56fa0239ae0a4fdc01f9.tar.gz
cacao-native: update hg version
* fixes segfaults and remove shutdownguard-patch, which is applied upstream * remove the pre-generated libtool files
-rw-r--r--recipes/cacao/cacao-native.inc13
-rw-r--r--recipes/cacao/cacao-native_hg.bb8
2 files changed, 16 insertions, 5 deletions
diff --git a/recipes/cacao/cacao-native.inc b/recipes/cacao/cacao-native.inc
index fc86e684c5..8501634f8c 100644
--- a/recipes/cacao/cacao-native.inc
+++ b/recipes/cacao/cacao-native.inc
@@ -34,3 +34,16 @@ export JAVAC="${STAGING_BINDIR_NATIVE}/ecj-initial"
# force usage of fastjar
export JAR="fastjar"
+
+do_configure_prepend () {
+ # Remove old libtool macros.
+ MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
+ for i in ${MACROS}; do
+ rm -f src/mm/boehm-gc/m4/$i
+ rm -f m4/$i
+ done
+ rm ltmain.sh
+ rm libtool
+ rm src/mm/boehm-gc/ltmain.sh
+ rm src/mm/boehm-gc/libtool
+}
diff --git a/recipes/cacao/cacao-native_hg.bb b/recipes/cacao/cacao-native_hg.bb
index 020dee39fe..9413633e73 100644
--- a/recipes/cacao/cacao-native_hg.bb
+++ b/recipes/cacao/cacao-native_hg.bb
@@ -1,11 +1,9 @@
require cacao-native.inc
PV = "1.1.0+hgr${SRCPV}"
-PR = "r5"
+PR = "r6"
-SRCREV = "c7bf150bfa46"
-SRC_URI = "hg://mips.complang.tuwien.ac.at/hg/;module=cacao;rev=${SRCREV} \
- file://cacao-shutdownguard.patch \
- "
+SRCREV = "cff92704c4e0"
+SRC_URI = "hg://mips.complang.tuwien.ac.at/hg/;module=cacao;rev=${SRCREV}"
S = "${WORKDIR}/cacao"