aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2012-02-16 23:43:09 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-02-21 12:32:47 +0100
commit57d2e51561f94c268ecaec1fecf560332b0b0d0b (patch)
tree12472aefc87c2ab1b3bf21a112c8ef159b749952
parentef0800f1736d18a5044cc41b32f979bf0ce7f205 (diff)
downloadopenembedded-57d2e51561f94c268ecaec1fecf560332b0b0d0b.tar.gz
libbecj-bootstrap: use sort for build order of the javafiles and introduce INC_PR, backported from meta-java
* on some filesystems find orders the files to build not the right way, using sort seems to fix it, thanks Stefan Ring for the patch * use INC_PR for better revision handling
-rw-r--r--recipes/ecj/libecj-bootstrap.inc4
-rw-r--r--recipes/ecj/libecj-bootstrap_3.6.1.bb2
-rw-r--r--recipes/ecj/libecj-bootstrap_3.6.bb2
3 files changed, 5 insertions, 3 deletions
diff --git a/recipes/ecj/libecj-bootstrap.inc b/recipes/ecj/libecj-bootstrap.inc
index 1adce625ec..bece3f0c24 100644
--- a/recipes/ecj/libecj-bootstrap.inc
+++ b/recipes/ecj/libecj-bootstrap.inc
@@ -6,6 +6,8 @@ LICENSE = "EPL"
DEPENDS = "fastjar-native jikes-initial virtual/java-initial"
+INC_PR = "r1"
+
inherit native java
S = "${WORKDIR}"
@@ -48,7 +50,7 @@ do_unpackpost() {
addtask unpackpost after do_unpack before do_patch
do_compile() {
- find source -name '*.java' > sourcefiles
+ find source -name '*.java' | LC_ALL=C sort > sourcefiles
split -l 25 sourcefiles ecj-sources.
# Compiling in place is done because the sources contain
diff --git a/recipes/ecj/libecj-bootstrap_3.6.1.bb b/recipes/ecj/libecj-bootstrap_3.6.1.bb
index 66e3fc14c7..d5da24ecd8 100644
--- a/recipes/ecj/libecj-bootstrap_3.6.1.bb
+++ b/recipes/ecj/libecj-bootstrap_3.6.1.bb
@@ -1,6 +1,6 @@
require libecj-bootstrap.inc
-PR = "r0"
+PR = "${INC_PR}.0"
SRC_URI = " \
http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.6.1-201009090800/ecjsrc-${PV}.zip \
diff --git a/recipes/ecj/libecj-bootstrap_3.6.bb b/recipes/ecj/libecj-bootstrap_3.6.bb
index faece53453..a4a8b70104 100644
--- a/recipes/ecj/libecj-bootstrap_3.6.bb
+++ b/recipes/ecj/libecj-bootstrap_3.6.bb
@@ -1,6 +1,6 @@
require libecj-bootstrap.inc
-PR = "r0"
+PR = "${INC_PR}.0"
SRC_URI = " \
http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.6-201006080911/ecjsrc-${PV}.zip \