summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libffi/libffi_3.3~rc0.bb
Commit message (Collapse)AuthorAgeFilesLines
* libffi: update to 3.3 finalAlexander Kanavin2019-12-041-40/+0
| | | | | | | | | Add a couple patches to address ppc(64) build failures. License-Update: copyright years Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libffi: fix upstream version checkAlexander Kanavin2019-08-301-0/+3
| | | | | | | | As there is no version newer than 3.3-rc0 yet, an exception from the check is needed. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libffi: Make it build for MIPS o32Peter Kjellerstedt2019-08-271-0/+1
| | | | | | | | | | | | | This solves the following errors: src/mips/o32.S: Assembler messages: src/mips/o32.S:286: Error: opcode not supported on this processor: mips32r2 (mips32r2) `s.d $f12,((16*4)-10*4)($fp)' src/mips/o32.S:287: Error: opcode not supported on this processor: mips32r2 (mips32r2) `s.d $f14,((16*4)-8*4)($fp)' Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* libffi: Upgrade to 3.3-rc0Khem Raj2019-08-221-0/+36
libffi 3.1 release has been a bit aged and new architectures, compilers have since been come on stage to compile it, we have been carrying patches, but its better to use the latest 3.3 rc0 which has lot of these issues handled and is in good shape. Use 3.3~rc0 for PV to keep room for upgrade path without PE bump fix the multilib header conflict file /usr/include/ffi.h from install of libffi-dev-3.2.1+3.3+rc0-r0.core2_32 conflicts with file from package lib64-libffi-dev-3.2.1+3.3+rc0-r0.x86_64 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>