aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
index 3c1360f9a3..00098553dd 100644
--- a/meta/recipes-devtools/perl/perl_5.14.2.bb
+++ b/meta/recipes-devtools/perl/perl_5.14.2.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
# We need gnugrep (for -I)
DEPENDS = "virtual/db grep-native"
DEPENDS += "gdbm zlib"
-PR = "r9"
+PR = "r10"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -150,9 +150,9 @@ do_configure() {
-e 's,@ARCH@-thread-multi,,g' \
-e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \
-e 's,@STAGINGDIR@,${STAGING_DIR_HOST},g' \
- -e "s%\([ \"^\',=]\+\)/usr/include%\1${STAGING_INCDIR}%g" \
- -e "s%\([ \"^\',=]\+\)/usr/lib/%\1${libdir}/%g" \
- -e "s%\([ \"^\',=]\+\)/usr/%\1${exec_prefix}/%g" \
+ -e "s%\([ \"^\',=]\+\)/usr/include\([ \"^\',=]\+\)%\1${STAGING_INCDIR}\2%g" \
+ -e "s%\([ \"^\',=]\+\)/usr/lib/\([ \"^\',=]\+\)%\1${libdir}/\2%g" \
+ -e "s%\([ \"^\',=]\+\)/usr/\([ \"^\',=]\+\)%\1${exec_prefix}/\2%g" \
-e "s%/perl5%/perl%g" \
config.sh-${TARGET_ARCH}-${TARGET_OS}