aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/icu/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/icu/files')
-rw-r--r--meta/recipes-support/icu/files/gccfix.patch13
-rw-r--r--meta/recipes-support/icu/files/noldlibpath.patch47
-rw-r--r--meta/recipes-support/icu/files/use-g++-for-linking.patch67
3 files changed, 127 insertions, 0 deletions
diff --git a/meta/recipes-support/icu/files/gccfix.patch b/meta/recipes-support/icu/files/gccfix.patch
new file mode 100644
index 0000000000..9291e921d3
--- /dev/null
+++ b/meta/recipes-support/icu/files/gccfix.patch
@@ -0,0 +1,13 @@
+Index: source/layoutex/ParagraphLayout.cpp
+===================================================================
+--- source.orig/layoutex/ParagraphLayout.cpp 2009-06-30 11:48:47.000000000 +0100
++++ source/layoutex/ParagraphLayout.cpp 2009-06-30 11:49:06.000000000 +0100
+@@ -798,7 +798,7 @@
+
+ return nullLanguageCode;
+ }
+-#elif
++#else
+
+ // TODO - dummy implementation for right now...
+ le_int32 ParagraphLayout::getLanguageCode(const Locale *locale)
diff --git a/meta/recipes-support/icu/files/noldlibpath.patch b/meta/recipes-support/icu/files/noldlibpath.patch
new file mode 100644
index 0000000000..eba3d805d4
--- /dev/null
+++ b/meta/recipes-support/icu/files/noldlibpath.patch
@@ -0,0 +1,47 @@
+Setting LD_LIBRARY_PATH is a really bad idea when cross compiling. Simplest way
+to disable this is to rename the variable as per the patch below, then its
+harmless. This is a hack.
+
+RP 10/6/2010
+
+Index: source/config/Makefile.inc.in
+===================================================================
+--- source.orig/config/Makefile.inc.in 2010-06-10 21:49:19.000000000 +0100
++++ source/config/Makefile.inc.in 2010-06-10 21:49:46.000000000 +0100
+@@ -126,7 +126,7 @@
+ ##################################################################
+ # Environment variable to set a runtime search path
+ # (Overridden when necessary in -mh files)
+-LDLIBRARYPATH_ENVVAR = LD_LIBRARY_PATH
++LDLIBRARYPATH_ENVVAR = LD_LIBRARY_PATH2
+
+ # Versioned target for a shared library
+ FINAL_SO_TARGET = $(SO_TARGET).$(SO_TARGET_VERSION)
+Index: source/icudefs.mk.in
+===================================================================
+--- source.orig/icudefs.mk.in 2010-06-10 21:51:03.000000000 +0100
++++ source/icudefs.mk.in 2010-06-10 21:51:09.000000000 +0100
+@@ -150,7 +150,7 @@
+ SHLIB.cc= $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared
+
+ # Environment variable to set a runtime search path
+-LDLIBRARYPATH_ENVVAR = LD_LIBRARY_PATH
++LDLIBRARYPATH_ENVVAR = LD_LIBRARY_PATH2
+
+ # Versioned target for a shared library.
+ FINAL_SO_TARGET = $(SO_TARGET).$(SO_TARGET_VERSION)
+Index: source/tools/genrb/gendtjar.pl
+===================================================================
+--- source.orig/tools/genrb/gendtjar.pl 2010-06-10 21:51:36.000000000 +0100
++++ source/tools/genrb/gendtjar.pl 2010-06-10 21:52:03.000000000 +0100
+@@ -68,8 +68,8 @@
+ $icuLibDir = abs_path($icuBinDir."/../lib");
+ $path .=":$icuBinDir:$icuLibDir";
+
+- $libpath = $ENV{'LD_LIBRARY_PATH'}.":$icuLibDir";
+- $ENV{'LD_LIBRARY_PATH'} = $libpath;
++ $libpath = $ENV{'LD_LIBRARY_PATH2'}.":$icuLibDir";
++ $ENV{'LD_LIBRARY_PATH2'} = $libpath;
+
+ #print ("##### LD_LIBRARY_PATH = $ENV{'LD_LIBRARY_PATH'}\n");
+
diff --git a/meta/recipes-support/icu/files/use-g++-for-linking.patch b/meta/recipes-support/icu/files/use-g++-for-linking.patch
new file mode 100644
index 0000000000..4702abc065
--- /dev/null
+++ b/meta/recipes-support/icu/files/use-g++-for-linking.patch
@@ -0,0 +1,67 @@
+---
+ tools/genccode/Makefile.in | 2 +-
+ tools/gencmn/Makefile.in | 2 +-
+ tools/genrb/Makefile.in | 2 +-
+ tools/pkgdata/Makefile.in | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+--- source.orig/tools/genccode/Makefile.in
++++ source/tools/genccode/Makefile.in
+@@ -76,11 +76,11 @@ check-local: all-local
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ $(TARGET) : $(OBJECTS)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+
+ %.$(SECTION): $(srcdir)/%.$(SECTION).in
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+--- source.orig/tools/gencmn/Makefile.in
++++ source/tools/gencmn/Makefile.in
+@@ -76,11 +76,11 @@ check-local: all-local
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ $(TARGET) : $(OBJECTS)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+ %.$(SECTION): $(srcdir)/%.$(SECTION).in
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+--- source.orig/tools/genrb/Makefile.in
++++ source/tools/genrb/Makefile.in
+@@ -84,11 +84,11 @@ Makefile: $(srcdir)/Makefile.in $(top_b
+
+ $(TARGET) : $(OBJECTS)
+ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+ $(DERB) : $(DERB_OBJ)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+
+ # This line is needed to serialize builds when the gmake -j option is used.
+ $(TARGET_STUB_NAME).$(SECTION): $(DERB_STUB_NAME).$(SECTION)
+
+--- source.orig/tools/pkgdata/Makefile.in
++++ source/tools/pkgdata/Makefile.in
+@@ -81,11 +81,11 @@ check-local: all-local
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ $(TARGET) : $(OBJECTS)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+
+ %.$(SECTION): $(srcdir)/%.$(SECTION).in
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status