summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/enchant/enchant_1.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/enchant/enchant_1.6.0.bb')
-rw-r--r--meta/recipes-support/enchant/enchant_1.6.0.bb14
1 files changed, 9 insertions, 5 deletions
diff --git a/meta/recipes-support/enchant/enchant_1.6.0.bb b/meta/recipes-support/enchant/enchant_1.6.0.bb
index b8bb27117a..97a47614cd 100644
--- a/meta/recipes-support/enchant/enchant_1.6.0.bb
+++ b/meta/recipes-support/enchant/enchant_1.6.0.bb
@@ -1,12 +1,13 @@
SUMMARY = "Enchant Spell checker API Library"
-SECTION = "libs"
+SECTION = "libs"
HOMEPAGE = "http://www.abisource.com/projects/enchant/"
BUGTRACKER = "http://bugzilla.abisource.com/enter_bug.cgi?product=Enchant"
-LICENSE = "LGPLv2.1+"
+
+LICENSE = "LGPLv2.1+"
LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=dfcbabf9131dc9a95febef6753a2958b \
file://src/enchant.h;beginline=1;endline=29;md5=8d881caa1d37523567e1d8f726675a18"
-DEPENDS = "aspell glib-2.0"
-RDEPENDS_${PN} = "aspell"
+
+DEPENDS = "aspell glib-2.0"
inherit autotools pkgconfig
@@ -21,8 +22,11 @@ EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${prefix} \
--enable-aspell br_cv_binreloc=no \
"
+export CXXFLAGS += " -L${STAGING_LIBDIR} -lstdc++ "
+
FILES_${PN} = "${bindir} ${libdir}/*${SOLIBS} ${datadir}/${BPN} ${libdir}/${BPN}/*.so"
FILES_${PN}-dev += "${libdir}/${BPN}/*{SOLIBSDEV} ${libdir}/${BPN}/*.la"
FILES_${PN}-staticdev += "${libdir}/${BPN}/*.a"
-export CXXFLAGS += " -L${STAGING_LIBDIR} -lstdc++ "
+RDEPENDS_${PN} += "aspell"
+