aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-rt/rt-tests')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb b/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
index c3806c1f7a..634b609bda 100644
--- a/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
@@ -1,4 +1,5 @@
-pickDESCRIPTION = "Python hardware latency detector"
+SUMMARY = "Hardware latency detector"
+DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)."
HOMEPAGE = "http://git.kernel.org/?p=linux/kernel/git/clrkwllms/rt-tests.git"
SECTION = "tests"
LICENSE = "GPLv2"
19 20 21 22 23 24 25 26 27 28 29
#@TYPE: Machine
#@NAME: 4G Systems mtx-1
#@DESCRIPTION: Machine configuration for the mtx-1 (aka MeshCube)

TARGET_ARCH = "mipsel"
PACKAGE_ARCHS = "all mipsel ${MACHINE}"

PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-1"

# md: is the --pad=.. necessary? I believe not.
# EXTRA_IMAGECMD_jffs2 = "--pad=0x1c00000 --little-endian --eraseblock=0x20000 -n"  
EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x20000 -n"  

# does not gain any speed and just creates problems:
# TARGET_CC_ARCH = "-march=mips32" 

USE_DEVFS = "1"
USE_VT = "0"
SERIAL_CONSOLE = "115200 tts/0 vt100"

BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-usb-storage kernel-module-scsi-mod kernel-module-sd-mod kernel-module-fat kernel-module-vfat kernel-module-usbnet kernel-module-mii"

PREFERRED_VERSION_yamon = "2.17"

# create srec files
IMAGE_POSTPROCESS_COMMAND += "\
	${TARGET_PREFIX}objcopy -O srec -I binary --adjust-vma 0xbe000000 ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.${type} ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.srec; \
	grep -v S7 ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.srec > ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.srec; \
	grep -v S0 ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_NAME}.flash.srec >> ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.srec; "