aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-rt/rt-tests')
-rw-r--r--meta/recipes-rt/rt-tests/files/added-missing-dependencies.patch50
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests.inc6
2 files changed, 54 insertions, 2 deletions
diff --git a/meta/recipes-rt/rt-tests/files/added-missing-dependencies.patch b/meta/recipes-rt/rt-tests/files/added-missing-dependencies.patch
new file mode 100644
index 0000000000..e4202823e3
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/files/added-missing-dependencies.patch
@@ -0,0 +1,50 @@
+From 82d28701486ba5a699544a168448bf93b1ccd7b1 Mon Sep 17 00:00:00 2001
+From: Jackie Huang <jackie.huang@windriver.com>
+Date: Thu, 6 Dec 2012 11:26:14 +0800
+Subject: [PATCH] Added missing dependencies
+
+Upstream-Status: Submitted [linux-rt-users]
+
+The following targets missed dependency on librttest.a:
+pi_stress
+rt-migrate-test
+hackbench
+
+Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+---
+ Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index fd3cdb3..60707a7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -68,14 +68,14 @@ cyclictest: cyclictest.o librttest.a
+ signaltest: signaltest.o librttest.a
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+-pi_stress: pi_stress.o
++pi_stress: pi_stress.o librttest.a
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ hwlatdetect: src/hwlatdetect/hwlatdetect.py
+ chmod +x src/hwlatdetect/hwlatdetect.py
+ ln -s src/hwlatdetect/hwlatdetect.py hwlatdetect
+
+-rt-migrate-test: rt-migrate-test.o
++rt-migrate-test: rt-migrate-test.o librttest.a
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ ptsematest: ptsematest.o librttest.a
+@@ -96,7 +96,7 @@ sendme: sendme.o librttest.a
+ pip_stress: pip_stress.o librttest.a
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+-hackbench: hackbench.o
++hackbench: hackbench.o librttest.a
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ librttest.a: rt-utils.o error.o rt-get_cpu.o
+--
+1.7.9.5
+
diff --git a/meta/recipes-rt/rt-tests/rt-tests.inc b/meta/recipes-rt/rt-tests/rt-tests.inc
index 6a699fc4d8..513ddaf068 100644
--- a/meta/recipes-rt/rt-tests/rt-tests.inc
+++ b/meta/recipes-rt/rt-tests/rt-tests.inc
@@ -5,9 +5,11 @@ PR = "r0"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/clrkwllms/rt-tests.git \
file://0001-rt-tests-Allow-for-user-specified-PYLIB.patch \
- file://0002-rt-tests-Break-out-install_hwlatdetect.patch"
+ file://0002-rt-tests-Break-out-install_hwlatdetect.patch \
+ file://added-missing-dependencies.patch \
+"
-INC_PR = "r0"
+INC_PR = "r1"
S = "${WORKDIR}/git"