summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt')
-rw-r--r--meta/recipes-qt/qt4/qt-4.7.4.inc3
-rw-r--r--meta/recipes-qt/qt4/qt4-embedded.inc3
-rw-r--r--meta/recipes-qt/qt4/qt4-native.inc3
-rw-r--r--meta/recipes-qt/qt4/qt4-native_4.7.4.bb2
-rw-r--r--meta/recipes-qt/qt4/qt4-x11-free.inc4
-rw-r--r--meta/recipes-qt/qt4/qt4.inc6
6 files changed, 10 insertions, 11 deletions
diff --git a/meta/recipes-qt/qt4/qt-4.7.4.inc b/meta/recipes-qt/qt4/qt-4.7.4.inc
index 7a3ba54cc8..8fda9ce85a 100644
--- a/meta/recipes-qt/qt4/qt-4.7.4.inc
+++ b/meta/recipes-qt/qt4/qt-4.7.4.inc
@@ -43,9 +43,6 @@ do_configure_prepend() {
${S}/configure
}
-QT_GLFLAGS ?= ""
-QT_CONFIG_FLAGS += " -xmlpatterns -no-rpath -qt3support -reduce-relocations -silent ${QT_GLFLAGS}"
-
do_compile() {
# Fixup missing wsegl header in some SGX SDKs
if ! [ -e ${STAGING_INCDIR}/wsegl.h ] ; then
diff --git a/meta/recipes-qt/qt4/qt4-embedded.inc b/meta/recipes-qt/qt4/qt4-embedded.inc
index c4f6e980d1..06b2432585 100644
--- a/meta/recipes-qt/qt4/qt4-embedded.inc
+++ b/meta/recipes-qt/qt4/qt4-embedded.inc
@@ -1,9 +1,8 @@
DESCRIPTION = "Qt is a versatile cross-platform application framework -- this is the embedded version."
SECTION = "libs"
-LICENSE = "LGPLv2.1 | GPLv3"
HOMEPAGE = "http://qt.nokia.com"
DEPENDS += "directfb tslib"
-INC_PR = "r37"
+INC_PR = "r38"
QT_BASE_NAME ?= "qt4-embedded"
QT_BASE_LIB ?= "libqt-embedded"
diff --git a/meta/recipes-qt/qt4/qt4-native.inc b/meta/recipes-qt/qt4/qt4-native.inc
index ebbee9be25..8a6eb4b69b 100644
--- a/meta/recipes-qt/qt4/qt4-native.inc
+++ b/meta/recipes-qt/qt4/qt4-native.inc
@@ -31,7 +31,8 @@ EXTRA_OECONF = "-prefix ${prefix} \
-verbose -release \
-embedded -no-freetype -no-glib -no-iconv \
-exceptions -xmlpatterns \
- -qt3support"
+ -qt3support \
+ -no-fast -silent -no-rpath"
# yank default -e, otherwise we get the following error:
# moc_qbuffer.cpp: No such file or directory
diff --git a/meta/recipes-qt/qt4/qt4-native_4.7.4.bb b/meta/recipes-qt/qt4/qt4-native_4.7.4.bb
index 3be4d736eb..688fb509fb 100644
--- a/meta/recipes-qt/qt4/qt4-native_4.7.4.bb
+++ b/meta/recipes-qt/qt4/qt4-native_4.7.4.bb
@@ -8,8 +8,6 @@ SRC_URI += "file://blacklist-diginotar-certs.diff \
# Find the g++.conf/linux.conf in the right directory.
FILESEXTRAPATHS =. "${FILE_DIRNAME}/qt-${PV}:"
-EXTRA_OECONF += " -no-fast -silent -no-rpath"
-
TOBUILD := "src/tools/bootstrap ${TOBUILD}"
SRC_URI[md5sum] = "9831cf1dfa8d0689a06c2c54c5c65aaf"
diff --git a/meta/recipes-qt/qt4/qt4-x11-free.inc b/meta/recipes-qt/qt4/qt4-x11-free.inc
index 029c61e447..53a44ad691 100644
--- a/meta/recipes-qt/qt4/qt4-x11-free.inc
+++ b/meta/recipes-qt/qt4/qt4-x11-free.inc
@@ -5,12 +5,12 @@ HOMEPAGE = "http://qt.nokia.com"
SECTION = "x11/libs"
DEPENDS += "virtual/libgl virtual/libx11 fontconfig libxft libxext libxrender libxrandr libxcursor"
-INC_PR = "r34"
+INC_PR = "r35"
QT_GLFLAGS ?= "${@base_contains('DISTRO_FEATURES', 'opengl', '-opengl', '-no-opengl', d)} "
QT_GLFLAGS_qemux86 = "-opengl"
QT_GLFLAGS_qemuppc = "-opengl"
-QT_CONFIG_FLAGS += "-no-xinerama -no-xkb ${QT_GLFLAGS}"
+QT_CONFIG_FLAGS += "-no-xinerama -no-xkb"
QT_BASE_NAME ?= "qt4"
QT_BASE_LIB ?= "libqt"
diff --git a/meta/recipes-qt/qt4/qt4.inc b/meta/recipes-qt/qt4/qt4.inc
index bec81b4645..3155cbb6df 100644
--- a/meta/recipes-qt/qt4/qt4.inc
+++ b/meta/recipes-qt/qt4/qt4.inc
@@ -11,12 +11,16 @@ QT_DISTRO_FLAGS_linuxstdbase = "-sm"
QT_SQL_DRIVER_FLAGS ?= "-no-sql-ibase -no-sql-mysql -no-sql-psql -no-sql-odbc -plugin-sql-sqlite"
+QT_GLFLAGS ?= ""
+
QT_CONFIG_FLAGS += "-release -no-cups -reduce-relocations \
-shared -no-nas-sound -no-nis \
-qt-gif -system-libjpeg -system-libpng -system-zlib \
-no-pch -qdbus -stl -glib -phonon -webkit \
+ -xmlpatterns -no-rpath -qt3support -silent \
${QT_SQL_DRIVER_FLAGS} \
- ${QT_DISTRO_FLAGS} "
+ ${QT_DISTRO_FLAGS} \
+ ${QT_GLFLAGS}"
EXTRA_OEMAKE = "-e"