summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt')
-rw-r--r--meta/recipes-qt/qt4/files/qmake-exists-check.patch19
-rw-r--r--meta/recipes-qt/qt4/qt4-tools-nativesdk.inc22
-rw-r--r--meta/recipes-qt/qt4/qt4-tools-nativesdk_4.8.0.bb2
3 files changed, 15 insertions, 28 deletions
diff --git a/meta/recipes-qt/qt4/files/qmake-exists-check.patch b/meta/recipes-qt/qt4/files/qmake-exists-check.patch
deleted file mode 100644
index 27d21e045b..0000000000
--- a/meta/recipes-qt/qt4/files/qmake-exists-check.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-qt4-tools-nativesdk: avoid rebuilding qmake
-
-qt4-tools-nativesdk patch to avoids building qmake in configure if it already exists
-(as it will, since we symlink it in from the native sysroot in do_configure)
-
-Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-Upstream-Status: Inappropriate [configuration]
-
---- qt-everywhere-opensource-src-4.6.3.orig/configure 2011-01-10 12:01:56.260607001 +0000
-+++ qt-everywhere-opensource-src-4.6.3/configure 2011-01-10 12:02:20.584607015 +0000
-@@ -4286,7 +4286,7 @@
- }
-
- # build qmake
--if true; then ###[ '!' -f "$outpath/bin/qmake" ];
-+if [ '!' -f "$outpath/bin/qmake" ]; then
- echo "Creating qmake. Please wait..."
-
- OLD_QCONFIG_H=
diff --git a/meta/recipes-qt/qt4/qt4-tools-nativesdk.inc b/meta/recipes-qt/qt4/qt4-tools-nativesdk.inc
index 64cc1aebea..efb61bf142 100644
--- a/meta/recipes-qt/qt4/qt4-tools-nativesdk.inc
+++ b/meta/recipes-qt/qt4/qt4-tools-nativesdk.inc
@@ -1,21 +1,22 @@
DESCRIPTION = "SDK tools for Qt/[X11|Mac|Embedded] version 4.x"
-DEPENDS = "zlib-nativesdk dbus-nativesdk libx11-nativesdk qt4-tools-native"
+DEPENDS = "zlib-nativesdk dbus-nativesdk libx11-nativesdk qt4-native"
SECTION = "libs"
HOMEPAGE = "http://qt.nokia.com"
LICENSE = "LGPLv2.1 | GPLv3"
-INC_PR = "r9"
+INC_PR = "r10"
FILESEXTRAPATHS =. "${FILE_DIRNAME}/qt-${PV}:"
inherit nativesdk qmake2
SRC_URI = "http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
+ file://0004-no-qmake.patch \
file://configure-lflags.patch \
file://qt-config.patch \
- file://qmake-exists-check.patch \
file://configure-paths.patch \
file://qt-dbus-const.patch \
+ file://target_qmake.patch \
file://g++.conf \
file://linux.conf"
@@ -66,11 +67,7 @@ do_configure() {
sed -i -e "s#gcc#${CC}#" mkspecs/common/g++-base.conf
fi
- # first launch configure to get qmake compiled for the nativesdk
- (echo o; echo yes) | CC="${CC}" CXX="${CXX}" ./configure ${EXTRA_OECONF} || true
-
- # then backup the binary and start again with a qmake which can run on the build host
- mv bin/qmake bin/qmake_nativesdk
+ # Use qmake from qt4-native for building
if [ ! -e bin/qmake ]; then
ln -sf ${STAGING_BINDIR_NATIVE}/qmake2 bin/qmake
fi
@@ -99,11 +96,18 @@ do_compile() {
for i in ${TOBUILD}; do
cd ${S}/$i && oe_runmake CC="${CC}" CXX="${CXX}"
done
+
+ # Build nativesdk qmake
+ export QMAKESPEC="${S}/mkspecs/${TARGET_OS}-oe-g++"
+ cd ${S}/qmake
+ ${OE_QMAKE_QMAKE}
+ oe_runmake CC="${CC}" CXX="${CXX}"
+ cd ${S}
}
do_install() {
install -d ${D}${bindir}
- install -m 0755 bin/qmake_nativesdk ${D}${bindir}/qmake2
+ install -m 0755 bin/qmake2 ${D}${bindir}/qmake2
for i in moc uic uic3 rcc lrelease lupdate qdbuscpp2xml qdbusxml2cpp; do
install -m 0755 bin/${i} ${D}${bindir}/${i}4
done
diff --git a/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.8.0.bb b/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.8.0.bb
index e615d364f0..02917fefa8 100644
--- a/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.8.0.bb
+++ b/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.8.0.bb
@@ -2,6 +2,8 @@ require qt4-tools-nativesdk.inc
PR = "${INC_PR}.0"
+SRC_URI += "file://qmake_pri_fixes.patch"
+
DEFAULT_PREFERENCE = "-1"
SRC_URI[md5sum] = "e8a5fdbeba2927c948d9f477a6abe904"