summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt')
-rw-r--r--meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb2
-rw-r--r--meta/recipes-qt/qt4/qt4.inc6
-rw-r--r--meta/recipes-qt/qt4/qt4_arch.inc2
3 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb b/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
index b3aa1e559c..bae0340faf 100644
--- a/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
+++ b/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
@@ -9,7 +9,7 @@ QT_GRAPHICS_SYSTEM ?= "raster"
VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
def _get_extra_rdepends(d):
- gs = d.getVar('QT_GRAPHICS_SYSTEM', 1)
+ gs = d.getVar('QT_GRAPHICS_SYSTEM', True)
if gs == "opengl":
return "qt4-plugin-graphicssystems-glgraphicssystem"
diff --git a/meta/recipes-qt/qt4/qt4.inc b/meta/recipes-qt/qt4/qt4.inc
index 2956aed604..4d719138ca 100644
--- a/meta/recipes-qt/qt4/qt4.inc
+++ b/meta/recipes-qt/qt4/qt4.inc
@@ -45,7 +45,7 @@ python __anonymous () {
lib_packages = []
dev_packages = []
dbg_packages = []
- for name in d.getVar("QT_LIB_NAMES", 1).split():
+ for name in d.getVar("QT_LIB_NAMES", True).split():
pkg = d.getVar("QT_BASE_LIB", True) + name.lower().replace("qt", "").replace("_", "-") + "4"
# NOTE: the headers for QtAssistantClient are different
incname = name.replace("QtAssistantClient", "QtAssistant")
@@ -61,10 +61,10 @@ python __anonymous () {
lib_packages.append(pkg)
dev_packages.append("%s-dev" % pkg)
dbg_packages.append("%s-dbg" % pkg)
- for name in d.getVar("OTHER_PACKAGES", 1).split():
+ for name in d.getVar("OTHER_PACKAGES", True).split():
dbg_packages.append("%s-dbg" % name)
- for name in d.getVar("QT_EXTRA_LIBS", 1).split():
+ for name in d.getVar("QT_EXTRA_LIBS", True).split():
pkg = d.getVar("QT_BASE_LIB", True) + name.lower().replace("qt", "").replace("_", "-") + "4"
d.setVar("FILES_%s" % pkg, "${libdir}/lib%(name)s.so.*" % locals())
d.setVar("FILES_%s-dev" % pkg, """${libdir}/lib%(name)s.prl
diff --git a/meta/recipes-qt/qt4/qt4_arch.inc b/meta/recipes-qt/qt4/qt4_arch.inc
index 46d65a20d7..bde68dc2e0 100644
--- a/meta/recipes-qt/qt4/qt4_arch.inc
+++ b/meta/recipes-qt/qt4/qt4_arch.inc
@@ -4,7 +4,7 @@ ARM_INSTRUCTION_SET = "arm"
def qt_arch(d):
import bb, re
- arch = d.getVar('TARGET_ARCH', 1)
+ arch = d.getVar('TARGET_ARCH', True)
if re.match("^i.86$", arch):
arch = "i386"
elif re.match("^arm.*", arch):