summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt')
-rw-r--r--meta/recipes-qt/qt-apps/qmmp_0.5.2.bb4
-rw-r--r--meta/recipes-qt/qt4/qt4.inc22
2 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-qt/qt-apps/qmmp_0.5.2.bb b/meta/recipes-qt/qt-apps/qmmp_0.5.2.bb
index 469351ce50..df18f91c90 100644
--- a/meta/recipes-qt/qt-apps/qmmp_0.5.2.bb
+++ b/meta/recipes-qt/qt-apps/qmmp_0.5.2.bb
@@ -31,8 +31,8 @@ PACKAGES_DYNAMIC = "qmmp-plugin-* "
python populate_packages_prepend () {
import os
- qmmp_libdir = bb.data.expand('${libdir}/qmmp', d)
- gd = bb.data.expand('${D}/${libdir}/qmmp', d)
+ qmmp_libdir = d.expand('${libdir}/qmmp')
+ gd = d.expand('${D}/${libdir}/qmmp')
plug_dirs = os.listdir(gd)
for plug_dir in plug_dirs:
diff --git a/meta/recipes-qt/qt4/qt4.inc b/meta/recipes-qt/qt4/qt4.inc
index 4d719138ca..2e70bd91e2 100644
--- a/meta/recipes-qt/qt4/qt4.inc
+++ b/meta/recipes-qt/qt4/qt4.inc
@@ -257,17 +257,17 @@ do_compile() {
}
python populate_packages_prepend() {
- translation_dir = bb.data.expand('${datadir}/${QT_DIR_NAME}/translations/', d)
- translation_name = bb.data.expand('${QT_BASE_NAME}-translation-%s', d)
+ translation_dir = d.expand('${datadir}/${QT_DIR_NAME}/translations/')
+ translation_name = d.expand('${QT_BASE_NAME}-translation-%s')
do_split_packages(d, translation_dir, '^(assistant|designer|linguist|qt|qtconfig|qvfb)_(.*)\.qm$', translation_name, '${PN} translation for %s', extra_depends='' )
- phrasebook_dir = bb.data.expand('${datadir}/${QT_DIR_NAME}/phrasebooks/', d)
- phrasebook_name = bb.data.expand('${QT_BASE_NAME}-phrasebook-%s', d)
+ phrasebook_dir = d.expand('${datadir}/${QT_DIR_NAME}/phrasebooks/')
+ phrasebook_name = d.expand('${QT_BASE_NAME}-phrasebook-%s')
import os;
- if os.path.exists("%s%s" % (bb.data.expand('${D}',d), phrasebook_dir)):
+ if os.path.exists("%s%s" % (d.expand('${D}'), phrasebook_dir)):
do_split_packages(d, phrasebook_dir, '^(.*)\.qph$', phrasebook_name, '${PN} phrasebook for %s', extra_depends='' )
else:
- bb.note("The path does not exist:", bb.data.expand('${D}', d), phrasebook_dir)
+ bb.note("The path does not exist:", d.expand('${D}'), phrasebook_dir)
# Package all the plugins and their -dbg version and create a meta package
def qtopia_split(path, name, glob):
@@ -275,17 +275,17 @@ python populate_packages_prepend() {
Split the package into a normal and -dbg package and then add the
new packages to the meta package.
"""
- plugin_dir = bb.data.expand('${libdir}/${QT_DIR_NAME}/plugins/%s/' % path, d)
- if not os.path.exists("%s%s" % (bb.data.expand('${D}',d), plugin_dir)):
- bb.note("The path does not exist:", bb.data.expand('${D}', d), plugin_dir)
+ plugin_dir = d.expand('${libdir}/${QT_DIR_NAME}/plugins/%s/' % path)
+ if not os.path.exists("%s%s" % (d.expand('${D}'), plugin_dir)):
+ bb.note("The path does not exist:", d.expand('${D}'), plugin_dir)
return
- plugin_name = bb.data.expand('${QT_BASE_NAME}-plugin-%s-%%s' % name, d)
+ plugin_name = d.expand('${QT_BASE_NAME}-plugin-%s-%%s' % name)
dev_packages = []
dev_hook = lambda file,pkg,b,c,d:dev_packages.append((file,pkg))
do_split_packages(d, plugin_dir, glob, plugin_name, '${PN} %s for %%s' % name, extra_depends='', hook=dev_hook)
# Create a -dbg package as well
- plugin_dir_dbg = bb.data.expand('${libdir}/${QT_DIR_NAME}/plugins/%s/.debug' % path, d)
+ plugin_dir_dbg = d.expand('${libdir}/${QT_DIR_NAME}/plugins/%s/.debug' % path)
packages = d.getVar('PACKAGES')
for (file,package) in dev_packages:
packages = "%s %s-dbg" % (packages, package)