summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb')
-rw-r--r--meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb12
1 files changed, 5 insertions, 7 deletions
diff --git a/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb b/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
index bae0340faf..e816a90ea8 100644
--- a/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
+++ b/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
@@ -3,10 +3,9 @@ SECTION = "x11/base"
LICENSE = "MIT-X"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-QT_GRAPHICS_SYSTEM ?= "raster"
+PR = "r1"
-# xserver-common, x11-common
-VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
+QT_GRAPHICS_SYSTEM ?= "raster"
def _get_extra_rdepends(d):
gs = d.getVar('QT_GRAPHICS_SYSTEM', True)
@@ -16,12 +15,11 @@ def _get_extra_rdepends(d):
return ""
do_install () {
- install -d ${D}/${sysconfdir}/X11/Xsession.d/
- cfg_file=${D}/${sysconfdir}/X11/Xsession.d/85xqt-graphicssystem
+ install -d ${D}/${sysconfdir}/profile.d/
+ cfg_file=${D}/${sysconfdir}/profile.d/qt-graphicssystem
echo "export QT_GRAPHICSSYSTEM=${QT_GRAPHICS_SYSTEM}" > $cfg_file
- chmod +x $cfg_file
}
-RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_xserver_common} ${@_get_extra_rdepends(d)}"
+RDEPENDS_${PN} = "${@_get_extra_rdepends(d)}"
PACKAGE_ARCH = "${MACHINE_ARCH}"