summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/kern-tools/kern-tools-native_git.bb')
-rw-r--r--meta/recipes-kernel/kern-tools/kern-tools-native_git.bb30
1 files changed, 19 insertions, 11 deletions
diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index 8ccd8cee14..8eff00821a 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -1,24 +1,32 @@
SUMMARY = "Tools for managing Yocto Project style branched kernels"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=a6c2fa8aef1bda400e2828845ba0d06c"
+DESCRIPTION = "Powerful set of tools or managing Yocto Linux kernel sources \
+and configuration data. You can use these tools to make a single configuration \
+change, apply multiple patches, or work with your own kernel sources."
+HOMEPAGE = "https://www.yoctoproject.org/"
+LICENSE = "GPL-2.0-only & MIT"
+LIC_FILES_CHKSUM = "\
+ file://tools/kgit;beginline=5;endline=9;md5=9c30e971d435e249624278c3e343e501 \
+ file://Kconfiglib/LICENSE.txt;md5=712177a72a3937909543eda3ad1bfb7c \
+"
-DEPENDS = "git-native"
+DEPENDS += "git-replacement-native"
-SRCREV = "b46b1c4f0973bf1eb09cf1191f5f4e69bcd0475d"
-PR = "r12"
-PV = "0.2+git${SRCPV}"
+SRCREV = "7160ebe8b865dd6028aef278efa219433db93f7e"
+PV = "0.3+git"
inherit native
-SRC_URI = "git://git.yoctoproject.org/yocto-kernel-tools.git"
-S = "${WORKDIR}"
-UPSTREAM_CHECK_COMMITS = "1"
+SRC_URI = "git://git.yoctoproject.org/yocto-kernel-tools.git;branch=master;protocol=https"
+S = "${WORKDIR}/git"
+
+do_configure() {
+ :
+}
do_compile() {
:
}
do_install() {
- cd ${S}/git
- make DESTDIR=${D}${bindir} install
+ oe_runmake DESTDIR=${D}${bindir} install
}