aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch')
-rw-r--r--meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch25
1 files changed, 11 insertions, 14 deletions
diff --git a/meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch b/meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch
index a285ad2789..0e196c0634 100644
--- a/meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch
+++ b/meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch
@@ -1,30 +1,27 @@
-Upstream-Status="Inappropriate [Would break behavior on Windows]"
-
We can't use #!/full/path/to/python -u as this can be longer than shebang
allows for. In order to be appropraite for upstream more work would be
needed to make sure that the main xml2po code doesn't rely on python
being invoked with -u (force stdin/out/err to be used raw).
----
- xml2po/xml2po/Makefile.am | 1 -
- xml2po/xml2po/xml2po.py.in | 2 +-
- 2 files changed, 1 insertion(+), 2 deletions(-)
-Index: gnome-doc-utils-0.20.6/xml2po/xml2po/Makefile.am
+Upstream-Status: Inappropriate [Would break behavior on Windows]
+Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
+
+Index: gnome-doc-utils-0.20.10/xml2po/xml2po/Makefile.am
===================================================================
---- gnome-doc-utils-0.20.6.orig/xml2po/xml2po/Makefile.am
-+++ gnome-doc-utils-0.20.6/xml2po/xml2po/Makefile.am
+--- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/Makefile.am
++++ gnome-doc-utils-0.20.10/xml2po/xml2po/Makefile.am
@@ -7,7 +7,6 @@ CLEANFILES = xml2po
xml2po: xml2po.py.in
- sed -e "s/^VERSION =.*/VERSION = \"@VERSION@\"/" \
+ $(AM_V_GEN)sed -e "s/^VERSION =.*/VERSION = \"@VERSION@\"/" \
- -e "s+^#!.*python.*+#!$(PYTHON)+" \
< $(srcdir)/xml2po.py.in > xml2po
- chmod +x xml2po
+ $(AM_V_at)chmod +x xml2po
-Index: gnome-doc-utils-0.20.6/xml2po/xml2po/xml2po.py.in
+Index: gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in
===================================================================
---- gnome-doc-utils-0.20.6.orig/xml2po/xml2po/xml2po.py.in
-+++ gnome-doc-utils-0.20.6/xml2po/xml2po/xml2po.py.in
+--- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/xml2po.py.in
++++ gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in
@@ -1,4 +1,4 @@
-#!/usr/bin/python -u
+#!/usr/bin/env python