summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/cups/cups14.inc2
-rw-r--r--meta/recipes-extended/lsof/lsof_4.85.bb6
-rw-r--r--meta/recipes-extended/pam/libpam_1.1.4.bb4
-rw-r--r--meta/recipes-extended/zip/zip.inc2
4 files changed, 7 insertions, 7 deletions
diff --git a/meta/recipes-extended/cups/cups14.inc b/meta/recipes-extended/cups/cups14.inc
index 48f493d6c7..8c01caf55e 100644
--- a/meta/recipes-extended/cups/cups14.inc
+++ b/meta/recipes-extended/cups/cups14.inc
@@ -58,7 +58,7 @@ fakeroot do_install () {
python do_package_append() {
# Change permissions back the way they were, they probably had a reason...
- workdir = bb.data.getVar('WORKDIR', d, 1)
+ workdir = d.getVar('WORKDIR', 1)
os.system('chmod 0511 %s/install/cups/var/run/cups/certs' % workdir)
}
diff --git a/meta/recipes-extended/lsof/lsof_4.85.bb b/meta/recipes-extended/lsof/lsof_4.85.bb
index 96bc0c54bc..8f25e24a50 100644
--- a/meta/recipes-extended/lsof/lsof_4.85.bb
+++ b/meta/recipes-extended/lsof/lsof_4.85.bb
@@ -17,10 +17,10 @@ LIC_FILES_CHKSUM = "file://${S}/00README;beginline=645;endline=679;md5=e0108f781
python do_unpack () {
bb.build.exec_func('base_do_unpack', d)
- src_uri = bb.data.getVar('SRC_URI', d)
- bb.data.setVar('SRC_URI', '${LOCALSRC}', d)
+ src_uri = d.getVar('SRC_URI')
+ d.setVar('SRC_URI', '${LOCALSRC}')
bb.build.exec_func('base_do_unpack', d)
- bb.data.setVar('SRC_URI', src_uri, d)
+ d.setVar('SRC_URI', src_uri)
}
export LSOF_OS = "${TARGET_OS}"
diff --git a/meta/recipes-extended/pam/libpam_1.1.4.bb b/meta/recipes-extended/pam/libpam_1.1.4.bb
index 868bffd960..afe17cc932 100644
--- a/meta/recipes-extended/pam/libpam_1.1.4.bb
+++ b/meta/recipes-extended/pam/libpam_1.1.4.bb
@@ -54,10 +54,10 @@ python populate_packages_prepend () {
def pam_plugin_append_file(pn, dir, file):
nf = os.path.join(dir, file)
- of = bb.data.getVar('FILES_' + pn, d, True)
+ of = d.getVar('FILES_' + pn, True)
if of:
nf = of + " " + nf
- bb.data.setVar('FILES_' + pn, nf, d)
+ d.setVar('FILES_' + pn, nf)
dvar = bb.data.expand('${WORKDIR}/package', d, True)
pam_libdir = bb.data.expand('${base_libdir}/security', d)
diff --git a/meta/recipes-extended/zip/zip.inc b/meta/recipes-extended/zip/zip.inc
index 9550447264..8cce146b18 100644
--- a/meta/recipes-extended/zip/zip.inc
+++ b/meta/recipes-extended/zip/zip.inc
@@ -5,7 +5,7 @@ SECTION = "console/utils"
LICENSE = "Info-ZIP"
LIC_FILES_CHKSUM = "file://LICENSE;md5=04d43c5d70b496c032308106e26ae17d"
-SRC_URI = "ftp://ftp.info-zip.org/pub/infozip/src/zip${@bb.data.getVar('PV',d,1).replace('.', '')}.tgz"
+SRC_URI = "ftp://ftp.info-zip.org/pub/infozip/src/zip${@d.getVar('PV',1).replace('.', '')}.tgz"
EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
'CFLAGS=-I. -DUNIX ${CFLAGS}' 'INSTALL=install' \