summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libnss-nis/libnss-nis.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libnss-nis/libnss-nis.bb')
-rw-r--r--meta/recipes-extended/libnss-nis/libnss-nis.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/libnss-nis/libnss-nis.bb b/meta/recipes-extended/libnss-nis/libnss-nis.bb
new file mode 100644
index 0000000000..f0e687c330
--- /dev/null
+++ b/meta/recipes-extended/libnss-nis/libnss-nis.bb
@@ -0,0 +1,31 @@
+# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "NSS module for glibc, to provide NIS support for glibc"
+
+DESCRIPTION = "This package contains the NSS NIS plugin for glibc.\
+This code was formerly part of glibc, but is now standalone to\
+be able to link against TI-RPC for IPv6 support."
+
+HOMEPAGE = "https://github.com/thkukuk/libnss_nis"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+SECTION = "libs"
+DEPENDS += "libtirpc libnsl2"
+
+PV = "3.2"
+
+SRCREV = "cd0d391af9535b56e612ed227c1b89be269f3d59"
+
+SRC_URI = "git://github.com/thkukuk/libnss_nis;branch=master;protocol=https \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+BBCLASSEXTEND += "native nativesdk"
+#
+# We will skip parsing this packagegeoup for non-glibc systems
+#
+COMPATIBLE_HOST:libc-musl = 'null'