aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.16.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.16.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.16.bb b/meta/recipes-extended/grep/grep_2.16.bb
new file mode 100644
index 0000000000..be39555147
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.16.bb
@@ -0,0 +1,38 @@
+SUMMARY = "GNU grep utility"
+HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
+BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
+SECTION = "console/utils"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
+
+SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "502350a6c8f7c2b12ee58829e760b44d"
+SRC_URI[sha256sum] = "16dfeb5013d8c9f21f40ccec0936f2c1c6a014c828d30488f0d5c6ef7b551162"
+
+inherit autotools gettext
+
+EXTRA_OECONF = "--disable-perl-regexp"
+
+do_configure_prepend () {
+ rm -f ${S}/m4/init.m4
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/grep ${D}${base_bindir}/grep
+ mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
+ mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
+ rmdir ${D}${bindir}/
+}
+
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+
+ALTERNATIVE_${PN} = "grep egrep fgrep"
+ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
+ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
+ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
+