aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/sgml-common
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/sgml-common')
-rw-r--r--meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb b/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
index 43553795f1..6098673a35 100644
--- a/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
+++ b/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
@@ -32,6 +32,7 @@ do_compile_append() {
FILES_${PN} += "${datadir}/sgml"
pkg_postinst_${PN}() {
+ if [ "x$D" = "x" ]; then
install-catalog \
--add ${sysconfdir}/sgml/sgml-ent.cat \
${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
@@ -39,6 +40,21 @@ pkg_postinst_${PN}() {
install-catalog \
--add ${sysconfdir}/sgml/sgml-docbook.cat \
${sysconfdir}/sgml/sgml-ent.cat
+ else
+ if ! grep -q ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog $D${sysconfdir}/sgml/sgml-ent.cat; then
+ echo "CATALOG ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog" >> $D${sysconfdir}/sgml/sgml-ent.cat
+ fi
+ if ! grep -q ${sysconfdir}/sgml/sgml-ent.cat $D${sysconfdir}/sgml/catalog; then
+ echo "CATALOG ${sysconfdir}/sgml/sgml-ent.cat" >> $D${sysconfdir}/sgml/catalog
+ fi
+
+ if ! grep -q ${sysconfdir}/sgml/sgml-ent.cat $D${sysconfdir}/sgml/sgml-docbook.cat; then
+ echo "CATALOG ${sysconfdir}/sgml/sgml-ent.cat" >> $D${sysconfdir}/sgml/sgml-docbook.cat
+ fi
+ if ! grep -q ${sysconfdir}/sgml/sgml-docbook.cat $D${sysconfdir}/sgml/catalog; then
+ echo "CATALOG ${sysconfdir}/sgml/sgml-docbook.cat" >> $D${sysconfdir}/sgml/catalog
+ fi
+ fi
}
pkg_postrm_${PN}() {