aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.2.bb2
-rw-r--r--meta/recipes-devtools/python/python3-nose_1.3.7.bb4
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_32.1.1.bb7
3 files changed, 10 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.2.bb b/meta/recipes-devtools/python/python3-native_3.5.2.bb
index 3f4b567278..782e2cda9f 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.2.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.2.bb
@@ -79,3 +79,5 @@ do_install() {
# Tests are large and we don't need them in the native sysroot
rm ${D}${libdir}/python${PYTHON_MAJMIN}/test -rf
}
+
+RPROVIDES += "python3-misc-native"
diff --git a/meta/recipes-devtools/python/python3-nose_1.3.7.bb b/meta/recipes-devtools/python/python3-nose_1.3.7.bb
index 99bba4403f..1e2ff74f57 100644
--- a/meta/recipes-devtools/python/python3-nose_1.3.7.bb
+++ b/meta/recipes-devtools/python/python3-nose_1.3.7.bb
@@ -17,6 +17,10 @@ S = "${WORKDIR}/nose-${PV}"
inherit setuptools3
+do_install_append() {
+ mv ${D}${bindir}/nosetests ${D}${bindir}/nosetests3
+}
+
RDEPENDS_${PN}_class-target = "\
python3-unittest \
"
diff --git a/meta/recipes-devtools/python/python3-setuptools_32.1.1.bb b/meta/recipes-devtools/python/python3-setuptools_32.1.1.bb
index 65af6f0dad..63f241809e 100644
--- a/meta/recipes-devtools/python/python3-setuptools_32.1.1.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_32.1.1.bb
@@ -2,6 +2,7 @@ require python-setuptools.inc
DEPENDS += "python3"
DEPENDS_class-native += "python3-native"
+DEPENDS_class-nativesdk += "nativesdk-python3"
inherit distutils3
@@ -14,11 +15,11 @@ do_install_append() {
echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
}
-RDEPENDS_${PN} = "\
+RDEPENDS_${PN}_class-native = "\
python3-distutils \
python3-compression \
"
-RDEPENDS_${PN}_class-target = "\
+RDEPENDS_${PN} = "\
python3-ctypes \
python3-distutils \
python3-email \
@@ -34,4 +35,4 @@ RDEPENDS_${PN}_class-target = "\
python3-unittest \
python3-xml \
"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"