aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-dbus_0.83.1.bb3
-rw-r--r--meta/recipes-devtools/python/python-gst_0.10.19.bb3
-rw-r--r--meta/recipes-devtools/python/python-imaging_1.1.7.bb3
-rw-r--r--meta/recipes-devtools/python/python-pycairo_1.8.10.bb3
-rw-r--r--meta/recipes-devtools/python/python-pycurl_7.19.0.bb3
-rw-r--r--meta/recipes-devtools/python/python-pygobject_2.21.1.bb3
-rw-r--r--meta/recipes-devtools/python/python-pygtk_2.17.0.bb3
-rw-r--r--meta/recipes-devtools/python/python-pyrex_0.9.9.bb3
-rw-r--r--meta/recipes-devtools/python/python-scons_2.0.1.bb3
-rw-r--r--meta/recipes-devtools/python/python_2.6.6.bb3
10 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-dbus_0.83.1.bb b/meta/recipes-devtools/python/python-dbus_0.83.1.bb
index d0c0bc6a28..d405ffa8c1 100644
--- a/meta/recipes-devtools/python/python-dbus_0.83.1.bb
+++ b/meta/recipes-devtools/python/python-dbus_0.83.1.bb
@@ -7,6 +7,9 @@ DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
PR = "ml0"
SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "5fdf3970aa0c00020289de7ba8f3be18"
+SRC_URI[sha256sum] = "ce283806f1af4f2322e183a276528a880b503c74972932bd09f06bdb7fcc1b99"
S = "${WORKDIR}/dbus-python-${PV}"
inherit distutils-base autotools pkgconfig
diff --git a/meta/recipes-devtools/python/python-gst_0.10.19.bb b/meta/recipes-devtools/python/python-gst_0.10.19.bb
index 6afc3bac22..16852d1a15 100644
--- a/meta/recipes-devtools/python/python-gst_0.10.19.bb
+++ b/meta/recipes-devtools/python/python-gst_0.10.19.bb
@@ -7,6 +7,9 @@ PR = "r0"
SRC_URI = "http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
file://python-path.patch"
+
+SRC_URI[md5sum] = "ddcef7d00bd88b0591cd6d910c36ec4b"
+SRC_URI[sha256sum] = "956f81a8c15daa3f17e688a0dc5a5d18a3118141066952d3b201a6ac0c52b415"
S = "${WORKDIR}/gst-python-${PV}"
LIC_FILES_CHKSUM = "file://COPYING;md5=39ff67e932b7bdfa9b78bad67151690b"
diff --git a/meta/recipes-devtools/python/python-imaging_1.1.7.bb b/meta/recipes-devtools/python/python-imaging_1.1.7.bb
index a711a25730..bd6fe1d227 100644
--- a/meta/recipes-devtools/python/python-imaging_1.1.7.bb
+++ b/meta/recipes-devtools/python/python-imaging_1.1.7.bb
@@ -10,6 +10,9 @@ PR = "ml0"
SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
file://path.patch"
+
+SRC_URI[md5sum] = "fc14a54e1ce02a0225be8854bfba478e"
+SRC_URI[sha256sum] = "895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/meta/recipes-devtools/python/python-pycairo_1.8.10.bb b/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
index 1ff603875a..7d73dc2ec4 100644
--- a/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
+++ b/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
@@ -9,6 +9,9 @@ DEPENDS = "cairo"
PR = "ml0"
SRC_URI = "http://cairographics.org/releases/py2cairo-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "87421a6a70304120555ba7ba238f3dc3"
+SRC_URI[sha256sum] = "b15f71019e42e06d86f7e8fe5587f07c3de5a59a6c3a071b25fe100796dbcd56"
S = "${WORKDIR}/pycairo-${PV}"
inherit distutils pkgconfig
diff --git a/meta/recipes-devtools/python/python-pycurl_7.19.0.bb b/meta/recipes-devtools/python/python-pycurl_7.19.0.bb
index 1a04767266..c8841f4405 100644
--- a/meta/recipes-devtools/python/python-pycurl_7.19.0.bb
+++ b/meta/recipes-devtools/python/python-pycurl_7.19.0.bb
@@ -16,6 +16,9 @@ SRC_URI = "\
http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
file://no-static-link.patch;patch=1 \
"
+
+SRC_URI[archive.md5sum] = "919d58fe37e69fe87ce4534d8b6a1c7b"
+SRC_URI[archive.sha256sum] = "eb782dfcc5a7c023539a077462b83c167e178128ee9f7201665b9fbb1a8b0642"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/meta/recipes-devtools/python/python-pygobject_2.21.1.bb b/meta/recipes-devtools/python/python-pygobject_2.21.1.bb
index b43844760b..ca93c68db6 100644
--- a/meta/recipes-devtools/python/python-pygobject_2.21.1.bb
+++ b/meta/recipes-devtools/python/python-pygobject_2.21.1.bb
@@ -9,6 +9,9 @@ MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1
SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
file://generate-constants.patch"
+
+SRC_URI[md5sum] = "c12eef0cd6725dc7245c3db78ef85d2d"
+SRC_URI[sha256sum] = "e6ae6c70966899d2040c82ae4e1590cf941ebf121a3ec61e80bf517ce8d9be0a"
S = "${WORKDIR}/pygobject-${PV}"
FILESPATH = "${FILE_DIRNAME}/python-pygobject:${FILE_DIRNAME}/files"
diff --git a/meta/recipes-devtools/python/python-pygtk_2.17.0.bb b/meta/recipes-devtools/python/python-pygtk_2.17.0.bb
index d3f4f50006..c32d9987ac 100644
--- a/meta/recipes-devtools/python/python-pygtk_2.17.0.bb
+++ b/meta/recipes-devtools/python/python-pygtk_2.17.0.bb
@@ -14,6 +14,9 @@ SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.17/${SRCNAME}-${PV}.tar
file://prevent_to_get_display_during_import.patch \
file://nodocs.patch \
file://acinclude.m4"
+
+SRC_URI[md5sum] = "43d704343d7ca04a6e4ddd4fa73a3c55"
+SRC_URI[sha256sum] = "6a61817a2e765c6209c72ecdf44389ec134c1ebed1d842408bf001c9321f1400"
S = "${WORKDIR}/${SRCNAME}-${PV}"
EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../"
diff --git a/meta/recipes-devtools/python/python-pyrex_0.9.9.bb b/meta/recipes-devtools/python/python-pyrex_0.9.9.bb
index b62ffbf26a..bba84ce4a5 100644
--- a/meta/recipes-devtools/python/python-pyrex_0.9.9.bb
+++ b/meta/recipes-devtools/python/python-pyrex_0.9.9.bb
@@ -12,6 +12,9 @@ SRC_URI = "\
http://www.cosc.canterbury.ac.nz/greg.ewing/python/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
file://pyrex-fix-optimized-mode.patch \
"
+
+SRC_URI[md5sum] = "515dee67d15d4393841e2d60e8341947"
+SRC_URI[sha256sum] = "5f87df06831d0b3412eb4bc9d3fc2ee7bfae1b913d7da8c23ab2bf5699fb6b50"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/meta/recipes-devtools/python/python-scons_2.0.1.bb b/meta/recipes-devtools/python/python-scons_2.0.1.bb
index 97a7a8c7ba..0dfa8379ed 100644
--- a/meta/recipes-devtools/python/python-scons_2.0.1.bb
+++ b/meta/recipes-devtools/python/python-scons_2.0.1.bb
@@ -8,6 +8,9 @@ SRCNAME = "scons"
PR = "r0"
SRC_URI = "${SOURCEFORGE_MIRROR}/scons/scons-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "beca648b894cdbf85383fffc79516d18"
+SRC_URI[sha256sum] = "0a8151da41c4a26c776c84f44f747ce03e093d43be3e83b38c14a76ab3256762"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/meta/recipes-devtools/python/python_2.6.6.bb b/meta/recipes-devtools/python/python_2.6.6.bb
index 50f8d70b04..b33e0a9e87 100644
--- a/meta/recipes-devtools/python/python_2.6.6.bb
+++ b/meta/recipes-devtools/python/python_2.6.6.bb
@@ -14,6 +14,9 @@ SRC_URI = "\
file://99-ignore-optimization-flag.patch \
file://sitecustomize.py \
"
+
+SRC_URI[md5sum] = "cf4e6881bb84a7ce6089e4a307f71f14"
+SRC_URI[sha256sum] = "134c5e0736bae2e5570d0b915693374f11108ded63c35a23a35d282737d2ce83"
S = "${WORKDIR}/Python-${PV}"
inherit autotools