aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/perl-tests.inc7
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb2
2 files changed, 5 insertions, 4 deletions
diff --git a/meta/recipes-devtools/perl/perl-tests.inc b/meta/recipes-devtools/perl/perl-tests.inc
index c968eb645b..e6de088769 100644
--- a/meta/recipes-devtools/perl/perl-tests.inc
+++ b/meta/recipes-devtools/perl/perl-tests.inc
@@ -21,12 +21,13 @@ do_install_append () {
cp -pv lib/AnyDBM_File.t ${D}${libdir}/perl/${PV}/
mkdir -p ${D}${libdir}/perl/${PV}/XS
- cp -pv lib/XS/{APItest,Typemap}.pm ${D}${libdir}/perl/${PV}/XS/
+ cp -pv lib/XS/APItest.pm ${D}${libdir}/perl/${PV}/XS/
+ cp -pv lib/XS/Typemap.pm ${D}${libdir}/perl/${PV}/XS/
mkdir -p ${D}${libdir}/perl/${PV}/auto/XS/APItest
cp -pv lib/auto/XS/APItest/APItest.so ${D}${libdir}/perl/${PV}/auto/XS/APItest/
cp -pv lib/auto/XS/Typemap/Typemap.so ${D}${libdir}/perl/${PV}/auto/XS/Typemap/
-
- cp -pv cpan/Digest-MD5/{README,MD5.xs} ${D}${PERL_TEST_DIR}/cpan/Digest-MD5/
+ cp -pv cpan/Digest-MD5/README ${D}${PERL_TEST_DIR}/cpan/Digest-MD5/
+ cp -pv cpan/Digest-MD5/MD5.xs ${D}${PERL_TEST_DIR}/cpan/Digest-MD5/
}
FILES_${PN}-tests = "${PERL_TEST_DIR} \
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
index 8678e76dec..e62e8ec657 100644
--- a/meta/recipes-devtools/perl/perl_5.14.2.bb
+++ b/meta/recipes-devtools/perl/perl_5.14.2.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
# We need gnugrep (for -I)
DEPENDS = "virtual/db grep-native"
DEPENDS += "gdbm zlib"
-PR = "r16"
+PR = "r17"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"