summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/librepo/librepo_1.10.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/librepo/librepo_1.10.6.bb')
-rw-r--r--meta/recipes-devtools/librepo/librepo_1.10.6.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/librepo/librepo_1.10.6.bb b/meta/recipes-devtools/librepo/librepo_1.10.6.bb
new file mode 100644
index 0000000000..cf4de22c47
--- /dev/null
+++ b/meta/recipes-devtools/librepo/librepo_1.10.6.bb
@@ -0,0 +1,27 @@
+SUMMARY = "A library providing C and Python (libcURL like) API \
+ for downloading linux repository metadata and packages."
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI = "git://github.com/rpm-software-management/librepo.git \
+ file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
+ file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
+ "
+
+SRCREV = "2ec349f1c686c1704dc83da6c118035ff57c8dea"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
+
+inherit cmake distutils3-base pkgconfig
+
+EXTRA_OECMAKE = " \
+ -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} \
+ -DPYTHON_DESIRED=3 \
+ -DENABLE_TESTS=OFF \
+ -DENABLE_DOCS=OFF \
+ -DWITH_ZCHUNK=OFF \
+"
+
+BBCLASSEXTEND = "native nativesdk"