aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/insserv/files/crosscompile_fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/insserv/files/crosscompile_fix.patch')
-rw-r--r--meta/recipes-devtools/insserv/files/crosscompile_fix.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/insserv/files/crosscompile_fix.patch b/meta/recipes-devtools/insserv/files/crosscompile_fix.patch
new file mode 100644
index 0000000000..14d8db468f
--- /dev/null
+++ b/meta/recipes-devtools/insserv/files/crosscompile_fix.patch
@@ -0,0 +1,22 @@
+Index: insserv-1.11.0/Makefile
+===================================================================
+--- insserv-1.11.0.orig/Makefile 2008-08-25 16:00:00.000000000 +0100
++++ insserv-1.11.0/Makefile 2008-08-25 16:00:25.000000000 +0100
+@@ -18,16 +18,7 @@
+ #
+ # Architecture
+ #
+-ifdef RPM_OPT_FLAGS
+- COPTS = -g $(RPM_OPT_FLAGS)
+-else
+- ARCH = $(shell uname -i)
+-ifeq ($(ARCH),i386)
+- COPTS = -O2 -mcpu=i586 -mtune=i686
+-else
+- COPTS = -O2
+-endif
+-endif
++COPTS = -O2
+ COPTS += -g
+
+ MY_CFLAGS = $(CFLAGS) -Wall $(COPTS) $(DEBUG) $(LOOPS) -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 \