aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/flex/flex.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/flex/flex.inc')
-rw-r--r--meta/recipes-devtools/flex/flex.inc21
1 files changed, 19 insertions, 2 deletions
diff --git a/meta/recipes-devtools/flex/flex.inc b/meta/recipes-devtools/flex/flex.inc
index 96d5de5f74..75c10ef340 100644
--- a/meta/recipes-devtools/flex/flex.inc
+++ b/meta/recipes-devtools/flex/flex.inc
@@ -6,9 +6,12 @@ HOMEPAGE = "http://sourceforge.net/projects/flex/"
SECTION = "devel"
LICENSE = "BSD"
-SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-${PV}.tar.bz2 "
+SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-${PV}.tar.bz2 \
+ file://run-ptest \
+"
+
+inherit autotools gettext ptest
-inherit autotools gettext
M4 = "${bindir}/m4"
M4_class-native = "${STAGING_BINDIR_NATIVE}/m4"
@@ -25,3 +28,17 @@ do_install_append_class-nativesdk() {
}
RDEPENDS_${PN} += "m4"
+DEPENDS_${PN}-ptest += "bison-native flex-native"
+
+do_compile_ptest() {
+ for i in `find ${S}/tests/ -type d |grep -Ev "concatenated-options|reject|table-opts" | awk -F/ '{print $NF}'`; \
+ do oe_runmake -C ${S}/tests/$i -f ${B}/tests/$i/Makefile top_builddir=${B} FLEX=flex $i; \
+ done
+ oe_runmake -C ${S}/tests/test-reject -f ${B}/tests/test-reject/Makefile top_builddir=${B} FLEX=flex test-reject-nr test-reject-r test-reject-ser test-reject-ver
+}
+
+do_install_ptest() {
+ for i in `find ${S}/tests/ -type d | awk -F/ '{print $NF}'`; \
+ do cp -r ${S}/tests/$i ${D}${PTEST_PATH}; \
+ done
+}