aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/acinclude.m486
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/debugfs-extent-header.patch47
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/debugfs-sparse-copy.patch148
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/debugfs-too-short.patch41
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/e2fsprogs-fix-tests-f_extent_oobounds.patch43
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/fallocate.patch22
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/fix-icache.patch69
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/mkdir.patch30
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/populate-extfs.sh96
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/quiet-debugfs.patch19
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/remove.ldconfig.call.patch44
11 files changed, 0 insertions, 645 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/acinclude.m4 b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/acinclude.m4
deleted file mode 100644
index 4b00668476..0000000000
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/acinclude.m4
+++ /dev/null
@@ -1,86 +0,0 @@
-# Extracted from the package's shipped aclocal.m4. Custom macros should be in
-# acinclude.m4 so running aclocal doesn't blow them away.
-#
-# RP 1/6/2010
-
-# ===========================================================================
-# http://www.nongnu.org/autoconf-archive/check_gnu_make.html
-# ===========================================================================
-#
-# SYNOPSIS
-#
-# CHECK_GNU_MAKE()
-#
-# DESCRIPTION
-#
-# This macro searches for a GNU version of make. If a match is found, the
-# makefile variable `ifGNUmake' is set to the empty string, otherwise it
-# is set to "#". This is useful for including a special features in a
-# Makefile, which cannot be handled by other versions of make. The
-# variable _cv_gnu_make_command is set to the command to invoke GNU make
-# if it exists, the empty string otherwise.
-#
-# Here is an example of its use:
-#
-# Makefile.in might contain:
-#
-# # A failsafe way of putting a dependency rule into a makefile
-# $(DEPEND):
-# $(CC) -MM $(srcdir)/*.c > $(DEPEND)
-#
-# @ifGNUmake@ ifeq ($(DEPEND),$(wildcard $(DEPEND)))
-# @ifGNUmake@ include $(DEPEND)
-# @ifGNUmake@ endif
-#
-# Then configure.in would normally contain:
-#
-# CHECK_GNU_MAKE()
-# AC_OUTPUT(Makefile)
-#
-# Then perhaps to cause gnu make to override any other make, we could do
-# something like this (note that GNU make always looks for GNUmakefile
-# first):
-#
-# if ! test x$_cv_gnu_make_command = x ; then
-# mv Makefile GNUmakefile
-# echo .DEFAULT: > Makefile ;
-# echo \ $_cv_gnu_make_command \$@ >> Makefile;
-# fi
-#
-# Then, if any (well almost any) other make is called, and GNU make also
-# exists, then the other make wraps the GNU make.
-#
-# LICENSE
-#
-# Copyright (c) 2008 John Darrington <j.darrington@elvis.murdoch.edu.au>
-#
-# Copying and distribution of this file, with or without modification, are
-# permitted in any medium without royalty provided the copyright notice
-# and this notice are preserved.
-#
-# Note: Modified by Ted Ts'o to add @ifNotGNUMake@
-
-AC_DEFUN(
- [CHECK_GNU_MAKE], [ AC_CACHE_CHECK( for GNU make,_cv_gnu_make_command,
- _cv_gnu_make_command='' ;
-dnl Search all the common names for GNU make
- for a in "$MAKE" make gmake gnumake ; do
- if test -z "$a" ; then continue ; fi ;
- if ( sh -c "$a --version" 2> /dev/null | grep GNU 2>&1 > /dev/null ) ; then
- _cv_gnu_make_command=$a ;
- break;
- fi
- done ;
- ) ;
-dnl If there was a GNU version, then set @ifGNUmake@ to the empty string, '#' otherwise
- if test "x$_cv_gnu_make_command" != "x" ; then
- ifGNUmake='' ;
- ifNotGNUmake='#' ;
- else
- ifGNUmake='#' ;
- ifNotGNUmake='' ;
- AC_MSG_RESULT("Not found");
- fi
- AC_SUBST(ifGNUmake)
- AC_SUBST(ifNotGNUmake)
-] )
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/debugfs-extent-header.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/debugfs-extent-header.patch
deleted file mode 100644
index ae44730192..0000000000
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/debugfs-extent-header.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-debugfs: properly set up extent header in do_write
-
-do_write doesn't fully set up the first extent header on a new
-inode, so if we write a 0-length file, and don't write any data
-to the new file, we end up creating something that looks corrupt
-to kernelspace:
-
-EXT4-fs error (device loop0): ext4_ext_check_inode:464: inode #12: comm ls: bad header/extent: invalid magic - magic 0, entries 0, max 0(0), depth 0(0)
-
-Do something similar to ext4_ext_tree_init() here, and
-fill out the first extent header upon creation to avoid this.
-
-Upstream-Status: Backport
-
-Reported-by: Robert Yang <liezhi.yang@windriver.com>
-Signed-off-by: Eric Sandeen <sandeen@redhat.com>
----
- debugfs/debugfs.c | 13 ++++++++++++-
- 1 file changed, 12 insertions(+), 1 deletion(-)
-
-diff --git a/debugfs/debugfs.c b/debugfs/debugfs.c
---- a/debugfs/debugfs.c
-+++ b/debugfs/debugfs.c
-@@ -1726,8 +1726,19 @@ void do_write(int argc, char *argv[])
- inode.i_links_count = 1;
- inode.i_size = statbuf.st_size;
- if (current_fs->super->s_feature_incompat &
-- EXT3_FEATURE_INCOMPAT_EXTENTS)
-+ EXT3_FEATURE_INCOMPAT_EXTENTS) {
-+ int i;
-+ struct ext3_extent_header *eh;
-+
-+ eh = (struct ext3_extent_header *) &inode.i_block[0];
-+ eh->eh_depth = 0;
-+ eh->eh_entries = 0;
-+ eh->eh_magic = EXT3_EXT_MAGIC;
-+ i = (sizeof(inode.i_block) - sizeof(*eh)) /
-+ sizeof(struct ext3_extent);
-+ eh->eh_max = ext2fs_cpu_to_le16(i);
- inode.i_flags |= EXT4_EXTENTS_FL;
-+ }
- if (debugfs_write_new_inode(newfile, &inode, argv[0])) {
- close(fd);
- return;
---
-1.8.1.2
-
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/debugfs-sparse-copy.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/debugfs-sparse-copy.patch
deleted file mode 100644
index 07124702a3..0000000000
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/debugfs-sparse-copy.patch
+++ /dev/null
@@ -1,148 +0,0 @@
-debugfs.c: do sparse copy when src is a sparse file
-
-Let debugfs do sparse copy when src is a sparse file, just like
-"cp --sparse=auto"
-
-* For the:
- #define IO_BUFSIZE 64*1024
- this is a suggested value from gnu coreutils:
- http://git.savannah.gnu.org/gitweb/?p=coreutils.git;a=blob;f=src/ioblksize.h;h=1ae93255e7d0ccf0855208c7ae5888209997bf16;hb=HEAD
-
-* Use malloc() to allocate memory for the buffer since put 64K (or
- more) on the stack seems not a good idea.
-
-Upstream-Status: Submitted
-
-Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-Acked-by: Darren Hart <dvhart@linux.intel.com>
----
- debugfs/debugfs.c | 62 +++++++++++++++++++++++++++++++++++++++++++++++++----
- 1 file changed, 58 insertions(+), 4 deletions(-)
-
-diff --git a/debugfs/debugfs.c b/debugfs/debugfs.c
---- a/debugfs/debugfs.c
-+++ b/debugfs/debugfs.c
-@@ -41,6 +41,16 @@ extern char *optarg;
- #define BUFSIZ 8192
- #endif
-
-+/* 64KiB is the minimium blksize to best minimize system call overhead. */
-+#ifndef IO_BUFSIZE
-+#define IO_BUFSIZE 64*1024
-+#endif
-+
-+/* Block size for `st_blocks' */
-+#ifndef S_BLKSIZE
-+#define S_BLKSIZE 512
-+#endif
-+
- ss_request_table *extra_cmds;
- const char *debug_prog_name;
- int sci_idx;
-@@ -1563,22 +1573,37 @@ void do_find_free_inode(int argc, char *argv[])
- }
-
- #ifndef READ_ONLY
--static errcode_t copy_file(int fd, ext2_ino_t newfile)
-+static errcode_t copy_file(int fd, ext2_ino_t newfile, int bufsize, int make_holes)
- {
- ext2_file_t e2_file;
- errcode_t retval;
- int got;
- unsigned int written;
-- char buf[8192];
-+ char *buf;
- char *ptr;
-+ char *zero_buf;
-+ int cmp;
-
- retval = ext2fs_file_open(current_fs, newfile,
- EXT2_FILE_WRITE, &e2_file);
- if (retval)
- return retval;
-
-+ if (!(buf = (char *) malloc(bufsize))){
-+ com_err("copy_file", errno, "can't allocate buffer\n");
-+ return;
-+ }
-+
-+ /* This is used for checking whether the whole block is zero */
-+ retval = ext2fs_get_memzero(bufsize, &zero_buf);
-+ if (retval) {
-+ com_err("copy_file", retval, "can't allocate buffer\n");
-+ free(buf);
-+ return retval;
-+ }
-+
- while (1) {
-- got = read(fd, buf, sizeof(buf));
-+ got = read(fd, buf, bufsize);
- if (got == 0)
- break;
- if (got < 0) {
-@@ -1586,6 +1611,21 @@ static errcode_t copy_file(int fd, ext2_ino_t newfile)
- goto fail;
- }
- ptr = buf;
-+
-+ /* Sparse copy */
-+ if (make_holes) {
-+ /* Check whether all is zero */
-+ cmp = memcmp(ptr, zero_buf, got);
-+ if (cmp == 0) {
-+ /* The whole block is zero, make a hole */
-+ retval = ext2fs_file_lseek(e2_file, got, EXT2_SEEK_CUR, NULL);
-+ if (retval)
-+ goto fail;
-+ got = 0;
-+ }
-+ }
-+
-+ /* Normal copy */
- while (got > 0) {
- retval = ext2fs_file_write(e2_file, ptr,
- got, &written);
-@@ -1596,10 +1636,14 @@ static errcode_t copy_file(int fd, ext2_ino_t newfile)
- ptr += written;
- }
- }
-+ free(buf);
-+ ext2fs_free_mem(&zero_buf);
- retval = ext2fs_file_close(e2_file);
- return retval;
-
- fail:
-+ free(buf);
-+ ext2fs_free_mem(&zero_buf);
- (void) ext2fs_file_close(e2_file);
- return retval;
- }
-@@ -1612,6 +1656,8 @@ void do_write(int argc, char *argv[])
- ext2_ino_t newfile;
- errcode_t retval;
- struct ext2_inode inode;
-+ int bufsize = IO_BUFSIZE;
-+ int make_holes = 0;
-
- if (common_args_process(argc, argv, 3, 3, "write",
- "<native file> <new file>", CHECK_FS_RW))
-@@ -1687,7 +1733,15 @@ void do_write(int argc, char *argv[])
- return;
- }
- if (LINUX_S_ISREG(inode.i_mode)) {
-- retval = copy_file(fd, newfile);
-+ if (statbuf.st_blocks < statbuf.st_size / S_BLKSIZE) {
-+ make_holes = 1;
-+ /*
-+ * Use I/O blocksize as buffer size when
-+ * copying sparse files.
-+ */
-+ bufsize = statbuf.st_blksize;
-+ }
-+ retval = copy_file(fd, newfile, bufsize, make_holes);
- if (retval)
- com_err("copy_file", retval, 0);
- }
---
-1.7.10.4
-
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/debugfs-too-short.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/debugfs-too-short.patch
deleted file mode 100644
index 607305be54..0000000000
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/debugfs-too-short.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-debugfs.c: the max length of debugfs argument is too short
-
-The max length of debugfs argument is 256 which is too short, the
-arguments are two paths, the PATH_MAX is 4096 according to
-/usr/include/linux/limits.h, so use BUFSIZ (which is 8192 on Linux
-systems), that's also what the ss library uses.
-
-Upstream-Status: Submitted
-
-Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-Acked-by: Darren Hart <dvhart@linux.intel.com>
----
- debugfs/debugfs.c | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/debugfs/debugfs.c b/debugfs/debugfs.c
---- a/debugfs/debugfs.c
-+++ b/debugfs/debugfs.c
-@@ -37,6 +37,10 @@ extern char *optarg;
- #include "../version.h"
- #include "jfs_user.h"
-
-+#ifndef BUFSIZ
-+#define BUFSIZ 8192
-+#endif
-+
- ss_request_table *extra_cmds;
- const char *debug_prog_name;
- int sci_idx;
-@@ -2311,7 +2315,7 @@ void do_dump_mmp(int argc EXT2FS_ATTR((unused)), char *argv[])
- static int source_file(const char *cmd_file, int ss_idx)
- {
- FILE *f;
-- char buf[256];
-+ char buf[BUFSIZ];
- char *cp;
- int exit_status = 0;
- int retval;
---
-1.8.1.2
-
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/e2fsprogs-fix-tests-f_extent_oobounds.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/e2fsprogs-fix-tests-f_extent_oobounds.patch
deleted file mode 100644
index a4f7077641..0000000000
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/e2fsprogs-fix-tests-f_extent_oobounds.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 1bfd0e015be7dd22a44995dd2a7002328aedc0e6 Mon Sep 17 00:00:00 2001
-From: Robert Yang <liezhi.yang@windriver.com>
-Date: Sat, 9 Nov 2013 22:24:37 +0800
-Subject: [PATCH] e2fsprogs: fix tests/f_extent_oobounds
-
-Use $DEBUGFS and $MKE2FS to get the in-tree executables
-for this test.
-
-(Build machines which run make check shouldn't need to have
-e2fsprogs installed, and we should be testing just-built versions
-of the tools anyway)
-
-This patch is from:
-http://www.spinics.net/lists/linux-ext4/msg38880.html
-
-Eric Sandeen had sent it to the upstream, but haven't been merge by now.
-
-Upstream-Status: Backport
-
-Signed-off-by: Eric Sandeen <sandeen@xxxxxxxxxx>
-Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
----
- tests/f_extent_oobounds/script | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/f_extent_oobounds/script b/tests/f_extent_oobounds/script
-index 31ac6c9..b00b031 100644
---- a/tests/f_extent_oobounds/script
-+++ b/tests/f_extent_oobounds/script
-@@ -4,8 +4,8 @@ SKIP_GUNZIP="true"
- TEST_DATA="$test_name.tmp"
-
- dd if=/dev/zero of=$TMPFILE bs=1k count=256 > /dev/null 2>&1
--mke2fs -Ft ext4 $TMPFILE > /dev/null 2>&1
--debugfs -w $TMPFILE << EOF > /dev/null 2>&1
-+$MKE2FS -Ft ext4 $TMPFILE > /dev/null 2>&1
-+$DEBUGFS -w $TMPFILE << EOF > /dev/null 2>&1
- write /dev/null testfile
- extent_open testfile
- insert_node 0 15 100
---
-1.8.3.1
-
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/fallocate.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/fallocate.patch
deleted file mode 100644
index d074c15cfd..0000000000
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/fallocate.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-We assume that fallocate is supported somehow
-but we need to check if we have fallocate()
-this problem shows up on uclibc systems since
-uclibc does not have fallocate() implemented
-
-Upstream-Status: Pending
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Index: e2fsprogs-1.42/lib/ext2fs/unix_io.c
-===================================================================
---- e2fsprogs-1.42.orig/lib/ext2fs/unix_io.c 2012-01-17 17:24:34.290780625 -0800
-+++ e2fsprogs-1.42/lib/ext2fs/unix_io.c 2012-01-17 17:25:37.338783680 -0800
-@@ -895,7 +895,7 @@
- goto unimplemented;
- #endif
- } else {
--#ifdef FALLOC_FL_PUNCH_HOLE
-+#if defined FALLOC_FL_PUNCH_HOLE && defined HAVE_FALLOCATE
- /*
- * If we are not on block device, try to use punch hole
- * to reclaim free space.
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/fix-icache.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/fix-icache.patch
deleted file mode 100644
index ad4e3439f4..0000000000
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/fix-icache.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-inode.c: only update the icache for ext2_inode
-
-We only read the cache when:
-
-bufsize == sizeof(struct ext2_inode)
-
-then we should only update the cache in the same condition, otherwise
-there would be errors, for example:
-
-cache[0]: cached ino 14 when bufsize = 128 by ext2fs_write_inode_full()
-cache[1]: cached ino 14 when bufsize = 156 by ext2fs_read_inode_full()
-
-Then update the cache:
-cache[0]: cached ino 15 when bufsize = 156 by ext2fs_read_inode_full()
-
-Then the ino 14 would hit the cache[1] when bufsize = 128 (but it was
-cached by bufsize = 156), so there would be errors.
-
-Note: the upstream has changed the icache lot, so this patch is
-inappropriate for the upstream, we can drop this patch when we update
-the package.
-
-Upstream-Status: [Inappropriate]
-
-Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
----
- lib/ext2fs/inode.c | 20 ++++++++++++--------
- 1 file changed, 12 insertions(+), 8 deletions(-)
-
-diff --git a/lib/ext2fs/inode.c b/lib/ext2fs/inode.c
---- a/lib/ext2fs/inode.c
-+++ b/lib/ext2fs/inode.c
-@@ -612,10 +612,12 @@ errcode_t ext2fs_read_inode_full(ext2_filsys fs, ext2_ino_t ino,
- #endif
-
- /* Update the inode cache */
-- fs->icache->cache_last = (fs->icache->cache_last + 1) %
-- fs->icache->cache_size;
-- fs->icache->cache[fs->icache->cache_last].ino = ino;
-- fs->icache->cache[fs->icache->cache_last].inode = *inode;
-+ if (bufsize == sizeof(struct ext2_inode)) {
-+ fs->icache->cache_last = (fs->icache->cache_last + 1) %
-+ fs->icache->cache_size;
-+ fs->icache->cache[fs->icache->cache_last].ino = ino;
-+ fs->icache->cache[fs->icache->cache_last].inode = *inode;
-+ }
-
- return 0;
- }
-@@ -648,10 +650,12 @@ errcode_t ext2fs_write_inode_full(ext2_filsys fs, ext2_ino_t ino,
-
- /* Check to see if the inode cache needs to be updated */
- if (fs->icache) {
-- for (i=0; i < fs->icache->cache_size; i++) {
-- if (fs->icache->cache[i].ino == ino) {
-- fs->icache->cache[i].inode = *inode;
-- break;
-+ if (bufsize == sizeof(struct ext2_inode)) {
-+ for (i=0; i < fs->icache->cache_size; i++) {
-+ if (fs->icache->cache[i].ino == ino) {
-+ fs->icache->cache[i].inode = *inode;
-+ break;
-+ }
- }
- }
- } else {
---
-1.8.1.2
-
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/mkdir.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/mkdir.patch
deleted file mode 100644
index aa7a2981b4..0000000000
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/mkdir.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Upstream-Status: Inappropriate [configuration]
-
-Signed-off-by: Mei Lei <lei.mei@intel.com>
-
-Index: e2fsprogs-1.41.5/po/Makefile.in.in
-===================================================================
---- e2fsprogs-1.41.5.orig/po/Makefile.in.in 2009-02-14 13:49:08.000000000 +0000
-+++ e2fsprogs-1.41.5/po/Makefile.in.in 2009-08-19 17:52:31.000000000 +0100
-@@ -30,7 +30,7 @@
- INSTALL = @INSTALL@
- INSTALL_DATA = @INSTALL_DATA@
- MKINSTALLDIRS = @MKINSTALLDIRS@
--mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
-+mkinstalldirs = $(MKINSTALLDIRS)
-
- GMSGFMT = @GMSGFMT@
- MSGFMT = @MSGFMT@
-Index: e2fsprogs-1.41.5/configure.in
-===================================================================
---- e2fsprogs-1.41.5.orig/configure.in 2009-08-19 17:53:50.000000000 +0100
-+++ e2fsprogs-1.41.5/configure.in 2009-08-19 17:48:38.000000000 +0100
-@@ -970,6 +970,8 @@
- fi
- AC_SUBST(BUILD_CFLAGS)
- AC_SUBST(BUILD_LDFLAGS)
-+MKINSTALLDIRS="mkdir -p"
-+AC_SUBST(MKINSTALLDIRS)
- dnl
- dnl Make our output files, being sure that we create the some miscellaneous
- dnl directories
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/populate-extfs.sh b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/populate-extfs.sh
deleted file mode 100644
index 7de720b115..0000000000
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/populate-extfs.sh
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/sh
-
-do_usage () {
- cat << _EOF
-Usage: populate-extfs.sh <source> <device>
-Create an ext2/ext3/ext4 filesystem from a directory or file
-
- source: The source directory or file
- device: The target device
-
-_EOF
- exit 1
-}
-
-[ $# -ne 2 ] && do_usage
-
-SRCDIR=${1%%/}
-DEVICE=$2
-DEBUGFS="debugfs"
-
-{
- CWD="/"
- find $SRCDIR | while read FILE; do
- TGT="${FILE##*/}"
- DIR="${FILE#$SRCDIR}"
- DIR="${DIR%$TGT}"
-
- # Skip the root dir
- [ ! -z "$DIR" ] || continue
- [ ! -z "$TGT" ] || continue
-
- if [ "$DIR" != "$CWD" ]; then
- echo "cd $DIR"
- CWD="$DIR"
- fi
-
- # Only stat once since stat is a time consuming command
- STAT=$(stat -c "TYPE=\"%F\";DEVNO=\"0x%t 0x%T\";MODE=\"%f\";U=\"%u\";G=\"%g\"" "$FILE")
- eval $STAT
-
- case $TYPE in
- "directory")
- echo "mkdir $TGT"
- ;;
- "regular file" | "regular empty file")
- echo "write \"$FILE\" \"$TGT\""
- ;;
- "symbolic link")
- LINK_TGT=$(readlink "$FILE")
- echo "symlink \"$TGT\" \"$LINK_TGT\""
- ;;
- "block special file")
- echo "mknod \"$TGT\" b $DEVNO"
- ;;
- "character special file")
- echo "mknod \"$TGT\" c $DEVNO"
- ;;
- "fifo")
- echo "mknod \"$TGT\" p"
- ;;
- *)
- echo "Unknown/unhandled file type '$TYPE' file: $FILE" 1>&2
- ;;
- esac
-
- # Set the file mode
- echo "sif \"$TGT\" mode 0x$MODE"
-
- # Set uid and gid
- echo "sif \"$TGT\" uid $U"
- echo "sif \"$TGT\" gid $G"
- done
-
- # Handle the hard links.
- # Save the hard links to a file, use the inode number as the filename, for example:
- # If a and b's inode number is 6775928, save a and b to /tmp/tmp.VrCwHh5gdt/6775928.
- INODE_DIR=`mktemp -d` || exit 1
- for i in `find $SRCDIR -type f -links +1 -printf 'INODE=%i###FN=%p\n'`; do
- eval `echo $i | sed 's$###$ $'`
- echo ${FN#$SRCDIR} >>$INODE_DIR/$INODE
- done
- # Use the debugfs' ln and "sif links_count" to handle them.
- for i in `ls $INODE_DIR`; do
- # The link source
- SRC=`head -1 $INODE_DIR/$i`
- # Remove the files and link them again except the first one
- for TGT in `sed -n -e '1!p' $INODE_DIR/$i`; do
- echo "rm $TGT"
- echo "ln $SRC $TGT"
- done
- LN_CNT=`cat $INODE_DIR/$i | wc -l`
- # Set the links count
- echo "sif $SRC links_count $LN_CNT"
- done
- rm -fr $INODE_DIR
-} | $DEBUGFS -w -f - $DEVICE
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/quiet-debugfs.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/quiet-debugfs.patch
deleted file mode 100644
index 830e9d57a5..0000000000
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/quiet-debugfs.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-When executing a script don't echo every command, as we do this for entire
-filesystems at rootfs time.
-
-Upstream-Status: Inappropriate
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-diff --git a/debugfs/debugfs.c b/debugfs/debugfs.c
-index 5590295..ac57292 100644
---- a/debugfs/debugfs.c
-+++ b/debugfs/debugfs.c
-@@ -2378,7 +2378,7 @@ static int source_file(const char *cmd_file, int ss_idx)
- cp = strchr(buf, '\r');
- if (cp)
- *cp = 0;
-- printf("debugfs: %s\n", buf);
-+ /*printf("debugfs: %s\n", buf);*/
- retval = ss_execute_line(ss_idx, buf);
- if (retval) {
- ss_perror(ss_idx, retval, buf);
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/remove.ldconfig.call.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/remove.ldconfig.call.patch
deleted file mode 100644
index f3e6eb778f..0000000000
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/remove.ldconfig.call.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From b139e03ac2f72e644e547c7ee9b1514383af4d97 Mon Sep 17 00:00:00 2001
-From: Andrei Dinu <andrei.adrianx.dinu@intel.com>
-Date: Wed, 30 Jan 2013 15:22:04 +0200
-Subject: [PATCH] When /etc/ld.so.cache is writeable by user running bitbake
- then it creates invalid cache (in my case libstdc++.so
- cannot be found after building zlib(-native) and I have to
- call touch */libstdc++.so && /sbin/ldconfig to fix it.
-
-So remove ldconfig call from make install-libs
-
-Patch authored by Martin Jansa.
-
-Upstream-Status: Inappropriate [disable feature]
-
-Signed-off-by: Scott Garman <scott.a.garman@intel.com>
-Signed-off-by: Andrei Dinu <andrei.adrianx.dinu@intel.com>
----
- lib/Makefile.elf-lib | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/lib/Makefile.elf-lib b/lib/Makefile.elf-lib
-index 78479d3..4a4a5ac 100644
---- a/lib/Makefile.elf-lib
-+++ b/lib/Makefile.elf-lib
-@@ -50,8 +50,6 @@ install-shlibs install:: $(ELF_LIB) installdirs-elf-lib $(DEP_INSTALL_SYMLINK)
- $(E) " SYMLINK $(libdir)/$(ELF_IMAGE).so"
- $(Q) $(INSTALL_SYMLINK) $(ELF_INSTALL_DIR)/$(ELF_SONAME) \
- $(libdir)/$(ELF_IMAGE).so $(DESTDIR)
-- $(E) " LDCONFIG"
-- $(Q) -$(LDCONFIG)
-
- install-strip: install
- $(E) " STRIP-LIB $(ELF_INSTALL_DIR)/$(ELF_LIB)"
-@@ -67,7 +65,6 @@ uninstall-shlibs uninstall::
- $(RM) -f $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_LIB) \
- $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_SONAME) \
- $(DESTDIR)$(libdir)/$(ELF_IMAGE).so
-- -$(LDCONFIG)
-
- clean::
- $(RM) -rf elfshared
---
-1.7.9.5
-