aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake')
-rw-r--r--meta/recipes-devtools/automake/automake.inc13
-rw-r--r--meta/recipes-devtools/automake/automake/path_prog_fixes.patch67
-rw-r--r--meta/recipes-devtools/automake/automake_1.11.1.bb41
3 files changed, 121 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake.inc b/meta/recipes-devtools/automake/automake.inc
new file mode 100644
index 0000000000..d68c45d4f7
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "A tool for automatically generating Makefiles."
+LICENSE = "GPLv2"
+HOMEPAGE = "http://www.gnu.org/software/automake/"
+SECTION = "devel"
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 "
+
+inherit autotools
+
+export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
+
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
diff --git a/meta/recipes-devtools/automake/automake/path_prog_fixes.patch b/meta/recipes-devtools/automake/automake/path_prog_fixes.patch
new file mode 100644
index 0000000000..fb38442e30
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake/path_prog_fixes.patch
@@ -0,0 +1,67 @@
+---
+ Makefile.am | 3 ++-
+ Makefile.in | 3 ++-
+ aclocal.in | 4 ++--
+ automake.in | 6 ++++--
+ 4 files changed, 10 insertions(+), 6 deletions(-)
+
+Index: automake-1.10.1/Makefile.am
+===================================================================
+--- automake-1.10.1.orig/Makefile.am 2008-01-21 22:28:58.000000000 +0000
++++ automake-1.10.1/Makefile.am 2008-10-10 17:21:20.000000000 +0100
+@@ -75,7 +75,8 @@
+ -e 's,[@]SHELL[@],$(SHELL),g' \
+ -e 's,[@]VERSION[@],$(VERSION),g' \
+ -e 's,[@]configure_input[@],Generated from $@.in; do not edit by hand.,g' \
+- -e 's,[@]datadir[@],$(datadir),g'
++ -e 's,[@]datadir[@],$(datadir),g' \
++ -e 's,[@]bindir[@],$(bindir),g'
+
+ ## These files depend on Makefile so they are rebuilt if $(VERSION),
+ ## $(datadir) or other do_subst'ituted variables change.
+Index: automake-1.10.1/Makefile.in
+===================================================================
+--- automake-1.10.1.orig/Makefile.in 2008-01-21 22:29:10.000000000 +0000
++++ automake-1.10.1/Makefile.in 2008-10-10 17:22:21.000000000 +0100
+@@ -185,7 +185,8 @@
+ -e 's,[@]SHELL[@],$(SHELL),g' \
+ -e 's,[@]VERSION[@],$(VERSION),g' \
+ -e 's,[@]configure_input[@],Generated from $@.in; do not edit by hand.,g' \
+- -e 's,[@]datadir[@],$(datadir),g'
++ -e 's,[@]datadir[@],$(datadir),g' \
++ -e 's,[@]bindir[@],$(bindir),g'
+
+ WGET = wget
+ WGET_SV_CVS = $(WGET) http://savannah.gnu.org/cgi-bin/viewcvs/~checkout~/
+Index: automake-1.10.1/aclocal.in
+===================================================================
+--- automake-1.10.1.orig/aclocal.in 2008-01-21 22:11:41.000000000 +0000
++++ automake-1.10.1/aclocal.in 2008-10-10 17:21:20.000000000 +0100
+@@ -1,8 +1,8 @@
+-#!@PERL@ -w
++#!@bindir@/env perl
+ # -*- perl -*-
+ # @configure_input@
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @bindir@/env perl -S "$0" "$@";; esac'
+ if 0;
+
+ # aclocal - create aclocal.m4 by scanning configure.ac
+Index: automake-1.10.1/automake.in
+===================================================================
+--- automake-1.10.1.orig/automake.in 2008-01-21 22:11:41.000000000 +0000
++++ automake-1.10.1/automake.in 2008-10-10 17:21:20.000000000 +0100
+@@ -1,8 +1,10 @@
+-#!@PERL@ -w
++#!@bindir@/env perl
+ # -*- perl -*-
+ # @configure_input@
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++use warnings;
++
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @bindir@/env perl -S "$0" "$@";; esac'
+ if 0;
+
+ # automake - create Makefile.in from Makefile.am
diff --git a/meta/recipes-devtools/automake/automake_1.11.1.bb b/meta/recipes-devtools/automake/automake_1.11.1.bb
new file mode 100644
index 0000000000..a78b6901f1
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.11.1.bb
@@ -0,0 +1,41 @@
+require automake.inc
+
+DEPENDS_virtclass-native = "autoconf-native"
+
+RDEPENDS_automake += "\
+ autoconf \
+ perl \
+ perl-module-bytes \
+ perl-module-constant \
+ perl-module-cwd \
+ perl-module-data-dumper \
+ perl-module-dynaloader \
+ perl-module-errno \
+ perl-module-exporter-heavy \
+ perl-module-file-basename \
+ perl-module-file-compare \
+ perl-module-file-copy \
+ perl-module-file-glob \
+ perl-module-file-spec-unix \
+ perl-module-file-stat \
+ perl-module-getopt-long \
+ perl-module-io \
+ perl-module-io-file \
+ perl-module-posix \
+ perl-module-strict \
+ perl-module-text-parsewords \
+ perl-module-vars "
+
+RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
+
+PATHFIXPATCH = "file://path_prog_fixes.patch;patch=1"
+PATHFIXPATCH_virtclass-native = ""
+
+SRC_URI += "${PATHFIXPATCH}"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+}
+
+BBCLASSEXTEND = "native"