summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/eglibc/eglibc-2.12/fix-for-make-3.82.diff25
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.12.bb5
2 files changed, 28 insertions, 2 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-2.12/fix-for-make-3.82.diff b/meta/recipes-core/eglibc/eglibc-2.12/fix-for-make-3.82.diff
new file mode 100644
index 0000000000..934d31ab89
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc-2.12/fix-for-make-3.82.diff
@@ -0,0 +1,25 @@
+Make 3.82, as shipped with Fedora 14, fixes some holes in the parser which in
+turn breaks behaviour of some Makefiles. Most notably eglibc's.
+
+http://www.mail-archive.com/bug-make@gnu.org/msg06220.html
+
+Fix back-ported from glibc/eglibc revision control.
+
+JL 13/10/10
+
+Index: libc/manual/Makefile
+===================================================================
+--- libc.orig/manual/Makefile
++++ libc/manual/Makefile
+@@ -243,7 +243,10 @@ ifdef objpfx
+ .PHONY: stubs
+ stubs: $(objpfx)stubs
+ endif
+-$(objpfx)stubs ../po/manual.pot $(objpfx)stamp%:
++$(objpfx)stubs ../po/manual.pot:
++ $(make-target-directory)
++ touch $@
++$(objpfx)stamp%:
+ $(make-target-directory)
+ touch $@
+
diff --git a/meta/recipes-core/eglibc/eglibc_2.12.bb b/meta/recipes-core/eglibc/eglibc_2.12.bb
index 752c1d8cee..9db1436ae6 100644
--- a/meta/recipes-core/eglibc/eglibc_2.12.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.12.bb
@@ -2,7 +2,7 @@ require eglibc.inc
DEPENDS += "gperf-native"
FILESPATHPKG =. "eglibc-svn:"
-PR = "r9"
+PR = "r10"
EGLIBC_BRANCH="eglibc-2_12"
SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \
@@ -11,7 +11,8 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http
file://shorten-build-commands.patch \
file://mips-rld-map-check.patch \
file://etc/ld.so.conf \
- file://generate-supported.mk"
+ file://generate-supported.mk \
+ file://fix-for-make-3.82.diff"
SRC_URI_append_virtclass-nativesdk = " file://ld-search-order.patch"
S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
B = "${WORKDIR}/build-${TARGET_SYS}"