aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb (renamed from meta/recipes-core/meta/external-python-tarball.bb)16
1 files changed, 12 insertions, 4 deletions
diff --git a/meta/recipes-core/meta/external-python-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
index 5f8cc964c1..076fe36d11 100644
--- a/meta/recipes-core/meta/external-python-tarball.bb
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -1,10 +1,8 @@
-DESCRIPTION = "Meta package for building a standalone python tarball"
+DESCRIPTION = "Meta package for building a standalone python tarball and other key build tools"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r2"
-
TOOLCHAIN_TARGET_TASK ?= ""
TOOLCHAIN_HOST_TASK ?= "\
@@ -26,10 +24,13 @@ TOOLCHAIN_HOST_TASK ?= "\
nativesdk-python-netclient \
nativesdk-python-netserver \
nativesdk-python-distutils \
+ nativesdk-python-unixadmin \
nativesdk-chrpath \
+ nativesdk-tar \
+ nativesdk-git \
"
-TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-python-nativesdk-standalone-${DISTRO_VERSION}"
+TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-buildtools-nativesdk-standalone-${DISTRO_VERSION}"
RDEPENDS = "${TOOLCHAIN_HOST_TASK}"
@@ -37,3 +38,10 @@ EXCLUDE_FROM_WORLD = "1"
inherit meta
inherit populate_sdk
+
+create_sdk_files_append () {
+ rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config*
+
+ cat ${SDK_OUTPUT}/${SDKPATH}/environment-setup* | grep " PATH=\|OECORE_NATIVE_SYSROOT" > ${WORKDIR}/envtmp
+ mv ${WORKDIR}/envtmp ${SDK_OUTPUT}/${SDKPATH}/environment-setup*
+}