aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb')
-rw-r--r--meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb b/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
new file mode 100644
index 0000000000..6861d8ad44
--- /dev/null
+++ b/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
@@ -0,0 +1,35 @@
+SECTION = "console/network"
+DESCRIPTION = "Enables PPP dial-in through a serial connection"
+DEPENDS = "ppp"
+RDEPENDS = "ppp"
+PR = "r5"
+LICENSE = "MIT"
+
+SRC_URI = "file://host-peer \
+ file://ppp-dialin"
+
+do_install() {
+ install -d ${D}${sysconfdir}/ppp/peers
+ install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host
+
+ install -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir}
+}
+
+PACKAGE_ARCH = "all"
+
+pkg_postinst() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ adduser --system --home /dev/null --no-create-home --empty-password --ingroup nogroup -s ${sbindir}/ppp-dialin ppp
+fi
+}
+
+pkg_postrm() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ deluser ppp
+fi
+}