aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/opensync
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/opensync')
-rw-r--r--meta/recipes-connectivity/opensync/libopensync-0.37/build-in-src.patch18
-rw-r--r--meta/recipes-connectivity/opensync/libopensync-0.37/cmake.patch17
-rw-r--r--meta/recipes-connectivity/opensync/libopensync-0.37/no-python-check.patch16
-rw-r--r--meta/recipes-connectivity/opensync/libopensync-plugin-evolution2/0.37-fixes.patch23
-rw-r--r--meta/recipes-connectivity/opensync/libopensync-plugin-evolution2_0.36.bb7
-rw-r--r--meta/recipes-connectivity/opensync/libopensync-plugin-file_0.37.bb1
-rw-r--r--meta/recipes-connectivity/opensync/libopensync-plugin-google-calendar_0.36.bb1
-rw-r--r--meta/recipes-connectivity/opensync/libopensync-plugin-irmc_0.36.bb3
-rw-r--r--meta/recipes-connectivity/opensync/libopensync-plugin-syncml/fixerror.patch13
-rw-r--r--meta/recipes-connectivity/opensync/libopensync-plugin-syncml_0.38.bb7
-rw-r--r--meta/recipes-connectivity/opensync/libopensync-plugin-vformat_0.37.bb3
-rw-r--r--meta/recipes-connectivity/opensync/libopensync-plugin_0.36.inc9
-rw-r--r--meta/recipes-connectivity/opensync/libopensync_0.37.bb25
-rw-r--r--meta/recipes-connectivity/opensync/libsync_svn.bb19
-rw-r--r--meta/recipes-connectivity/opensync/libsyncml/build-in-src.patch19
-rw-r--r--meta/recipes-connectivity/opensync/libsyncml_0.5.4.bb17
-rw-r--r--meta/recipes-connectivity/opensync/msynctool_0.37.bb7
17 files changed, 205 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/opensync/libopensync-0.37/build-in-src.patch b/meta/recipes-connectivity/opensync/libopensync-0.37/build-in-src.patch
new file mode 100644
index 0000000000..1810b339a6
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libopensync-0.37/build-in-src.patch
@@ -0,0 +1,18 @@
+---
+ cmake/OpenSyncInternal.cmake.in | 1 -
+ 1 file changed, 1 deletion(-)
+
+--- libopensync-0.36.orig/cmake/OpenSyncInternal.cmake.in
++++ libopensync-0.36/cmake/OpenSyncInternal.cmake.in
+@@ -5,11 +5,10 @@ INCLUDE( OpenSyncTesting )
+ INCLUDE( OpenSyncPackaging )
+ INCLUDE( OpenSyncPlugin )
+ INCLUDE( OpenSyncPlatforms )
+ INCLUDE( MacroEnsureOutOfSourceBuild )
+
+-MACRO_ENSURE_OUT_OF_SOURCE_BUILD("${CMAKE_PROJECT_NAME} doesn't allow to build within the source directory. Please, create a seperate build directory and run 'cmake ${PROJECT_SOURCE_DIR} [options]'!")
+
+
+ SET( OPENSYNC_PLUGINDIR "@OPENSYNC_PLUGINDIR@" )
+ SET( OPENSYNC_FORMATSDIR "@OPENSYNC_FORMATSDIR@" )
+ SET( OPENSYNC_PYTHON_PLUGINDIR "@OPENSYNC_PYTHON_PLUGINDIR@" )
diff --git a/meta/recipes-connectivity/opensync/libopensync-0.37/cmake.patch b/meta/recipes-connectivity/opensync/libopensync-0.37/cmake.patch
new file mode 100644
index 0000000000..7ea4613548
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libopensync-0.37/cmake.patch
@@ -0,0 +1,17 @@
+---
+ opensync/CMakeLists.txt | 1 -
+ 1 file changed, 1 deletion(-)
+
+Index: libopensync-0.37/opensync/CMakeLists.txt
+===================================================================
+--- libopensync-0.37.orig/opensync/CMakeLists.txt 2008-10-15 13:56:45.000000000 +0100
++++ libopensync-0.37/opensync/CMakeLists.txt 2008-10-15 13:59:03.000000000 +0100
+@@ -67,8 +67,6 @@
+ SET_TARGET_PROPERTIES( opensync PROPERTIES VERSION ${OPENSYNC_LIBVERSION_VERSION} )
+ SET_TARGET_PROPERTIES( opensync PROPERTIES SOVERSION ${OPENSYNC_LIBVERSION_SOVERSION} )
+
+-SET_TARGET_PROPERTIES( opensync PROPERTIES COMPILE_FLAGS ${SYMBOLS_VISIBILITY} )
+-
+ IF ( OPENSYNC_UNITTESTS )
+ ADD_LIBRARY( opensync-testing SHARED ${libopensync_LIB_SRCS} )
+ TARGET_LINK_LIBRARIES( opensync-testing ${GLIB2_LIBRARIES} ${GTHREAD2_LIBRARIES} ${GMODULE2_LIBRARIES} ${LIBXML2_LIBRARIES} ${LIBXSLT_LIBRARIES} ${LIBEXSLT_LIBRARIES} ${SQLITE3_LIBRARIES} )
diff --git a/meta/recipes-connectivity/opensync/libopensync-0.37/no-python-check.patch b/meta/recipes-connectivity/opensync/libopensync-0.37/no-python-check.patch
new file mode 100644
index 0000000000..04257bc623
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libopensync-0.37/no-python-check.patch
@@ -0,0 +1,16 @@
+---
+ CMakeLists.txt | 1 -
+ 1 file changed, 1 deletion(-)
+
+Index: libopensync-0.37/CMakeLists.txt
+===================================================================
+--- libopensync-0.37.orig/CMakeLists.txt 2008-08-18 16:14:24.000000000 +0100
++++ libopensync-0.37/CMakeLists.txt 2008-10-15 14:00:12.000000000 +0100
+@@ -65,7 +65,6 @@
+ FIND_PACKAGE( LibXslt REQUIRED )
+ FIND_PACKAGE( LibExslt REQUIRED )
+ FIND_PACKAGE( SWIG )
+-FIND_PACKAGE( PythonLibs )
+ FIND_PACKAGE( Check )
+
+ ADD_SUBDIRECTORY( opensync )
diff --git a/meta/recipes-connectivity/opensync/libopensync-plugin-evolution2/0.37-fixes.patch b/meta/recipes-connectivity/opensync/libopensync-plugin-evolution2/0.37-fixes.patch
new file mode 100644
index 0000000000..4a1802ce17
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libopensync-plugin-evolution2/0.37-fixes.patch
@@ -0,0 +1,23 @@
+Index: libopensync-plugin-evolution2-0.36/cmake/modules/FindOpenSync.cmake
+===================================================================
+--- libopensync-plugin-evolution2-0.36.orig/cmake/modules/FindOpenSync.cmake 2008-10-20 13:07:14.000000000 +0100
++++ libopensync-plugin-evolution2-0.36/cmake/modules/FindOpenSync.cmake 2008-10-20 13:08:09.000000000 +0100
+@@ -23,15 +23,15 @@
+ ENDIF ( OpenSync_FIND_REQUIRED )
+
+ IF ( OPENSYNC_MIN_VERSION )
+- PKG_SEARCH_MODULE( OPENSYNC ${_pkgconfig_REQUIRED} opensync-1.0>=${OPENSYNC_MIN_VERSION} )
++ PKG_SEARCH_MODULE( OPENSYNC ${_pkgconfig_REQUIRED} libopensync>=${OPENSYNC_MIN_VERSION} )
+ ELSE ( OPENSYNC_MIN_VERSION )
+- PKG_SEARCH_MODULE( OPENSYNC ${_pkgconfig_REQUIRED} opensync-1.0 )
++ PKG_SEARCH_MODULE( OPENSYNC ${_pkgconfig_REQUIRED} libopensync )
+ ENDIF ( OPENSYNC_MIN_VERSION )
+
+ FIND_PROGRAM( PKGCONFIG_EXECUTABLE NAMES pkg-config )
+
+ IF ( PKGCONFIG_EXECUTABLE )
+- EXEC_PROGRAM( ${PKGCONFIG_EXECUTABLE} ARGS opensync-1.0 --variable=datadir OUTPUT_VARIABLE _opensync_data_DIR )
++ EXEC_PROGRAM( ${PKGCONFIG_EXECUTABLE} ARGS libopensync --variable=datadir OUTPUT_VARIABLE _opensync_data_DIR )
+ STRING( REGEX REPLACE "[\r\n]" " " _opensync_data_DIR "${_opensync_data_DIR}" )
+ ENDIF ( PKGCONFIG_EXECUTABLE )
+
diff --git a/meta/recipes-connectivity/opensync/libopensync-plugin-evolution2_0.36.bb b/meta/recipes-connectivity/opensync/libopensync-plugin-evolution2_0.36.bb
new file mode 100644
index 0000000000..a1c4cb1887
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libopensync-plugin-evolution2_0.36.bb
@@ -0,0 +1,7 @@
+require libopensync-plugin_0.36.inc
+
+DEPENDS += " eds-dbus"
+
+SRC_URI += "file://0.37-fixes.patch;patch=1"
+
+PR = "r1"
diff --git a/meta/recipes-connectivity/opensync/libopensync-plugin-file_0.37.bb b/meta/recipes-connectivity/opensync/libopensync-plugin-file_0.37.bb
new file mode 100644
index 0000000000..33a049b7d6
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libopensync-plugin-file_0.37.bb
@@ -0,0 +1 @@
+require libopensync-plugin_0.36.inc
diff --git a/meta/recipes-connectivity/opensync/libopensync-plugin-google-calendar_0.36.bb b/meta/recipes-connectivity/opensync/libopensync-plugin-google-calendar_0.36.bb
new file mode 100644
index 0000000000..33a049b7d6
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libopensync-plugin-google-calendar_0.36.bb
@@ -0,0 +1 @@
+require libopensync-plugin_0.36.inc
diff --git a/meta/recipes-connectivity/opensync/libopensync-plugin-irmc_0.36.bb b/meta/recipes-connectivity/opensync/libopensync-plugin-irmc_0.36.bb
new file mode 100644
index 0000000000..c06de2fde8
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libopensync-plugin-irmc_0.36.bb
@@ -0,0 +1,3 @@
+require libopensync-plugin_0.36.inc
+
+DEPENDS += "openobex bluez4"
diff --git a/meta/recipes-connectivity/opensync/libopensync-plugin-syncml/fixerror.patch b/meta/recipes-connectivity/opensync/libopensync-plugin-syncml/fixerror.patch
new file mode 100644
index 0000000000..7dad889422
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libopensync-plugin-syncml/fixerror.patch
@@ -0,0 +1,13 @@
+Index: libopensync-plugin-syncml-0.38/src/syncml_callbacks.c
+===================================================================
+--- libopensync-plugin-syncml-0.38.orig/src/syncml_callbacks.c 2009-07-31 10:30:33.000000000 +0100
++++ libopensync-plugin-syncml-0.38/src/syncml_callbacks.c 2009-07-31 10:30:39.000000000 +0100
+@@ -405,7 +405,7 @@
+ } else {
+ /* This problem should be fixed with the next SLOW-SYNC. */
+ osync_trace(TRACE_EXIT_ERROR, "%s - unexpected Add or Replace command", __func__);
+- smlErrorSet(error, SML_ERROR_TEMPORARY, "Unwanted Add or Replace command on second OMA DS session.");
++ smlErrorSet(error, SML_ERROR_GENERIC, "Unwanted Add or Replace command on second OMA DS session.");
+ return FALSE;
+ }
+ }
diff --git a/meta/recipes-connectivity/opensync/libopensync-plugin-syncml_0.38.bb b/meta/recipes-connectivity/opensync/libopensync-plugin-syncml_0.38.bb
new file mode 100644
index 0000000000..d32d62de47
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libopensync-plugin-syncml_0.38.bb
@@ -0,0 +1,7 @@
+require libopensync-plugin_0.36.inc
+
+DEPENDS += " libsyncml (>= 0.4.7)"
+
+SRC_URI += "file://fixerror.patch;patch=1"
+
+PR = "r1" \ No newline at end of file
diff --git a/meta/recipes-connectivity/opensync/libopensync-plugin-vformat_0.37.bb b/meta/recipes-connectivity/opensync/libopensync-plugin-vformat_0.37.bb
new file mode 100644
index 0000000000..84a48f21fe
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libopensync-plugin-vformat_0.37.bb
@@ -0,0 +1,3 @@
+require libopensync-plugin_0.36.inc
+
+DEPENDS += " check"
diff --git a/meta/recipes-connectivity/opensync/libopensync-plugin_0.36.inc b/meta/recipes-connectivity/opensync/libopensync-plugin_0.36.inc
new file mode 100644
index 0000000000..db6b1fa73a
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libopensync-plugin_0.36.inc
@@ -0,0 +1,9 @@
+DEPENDS = "libopensync (>= 0.36)"
+
+SRC_URI = "http://opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+inherit cmake
+
+FILES_${PN} += "${libdir}/opensync*/plugins/*.so \
+ ${libdir}/opensync*/formats/*.so \
+ ${datadir}/opensync*/defaults/"
diff --git a/meta/recipes-connectivity/opensync/libopensync_0.37.bb b/meta/recipes-connectivity/opensync/libopensync_0.37.bb
new file mode 100644
index 0000000000..e9b8ce202e
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libopensync_0.37.bb
@@ -0,0 +1,25 @@
+LICENSE = "LGPL"
+HOMEPAGE = "http://www.opensync.org/"
+
+DEPENDS = "sqlite3 libxml2 glib-2.0 check zlib libxslt"
+
+PR = "r1"
+
+SRC_URI = "http://opensync.org/download/releases/${PV}/libopensync-${PV}.tar.bz2\
+ file://cmake.patch;patch=1 \
+ file://build-in-src.patch;patch=1 \
+ file://no-python-check.patch;patch=1"
+
+inherit cmake pkgconfig
+
+LEAD_SONAME = "libopensync.so"
+
+FILES_${PN} += " ${libdir}/opensync*/formats/*.so \
+ ${libdir}/opensync*/osplugin \
+ ${datadir}/opensync*/schemas \
+ ${datadir}/opensync*/capabilities \
+ ${datadir}/opensync*/descriptions \
+ "
+FILES_${PN}-dbg += " ${libdir}/opensync*/formats/.debug/*.so \
+ ${libdir}/opensync*/.debug/osplugin "
+
diff --git a/meta/recipes-connectivity/opensync/libsync_svn.bb b/meta/recipes-connectivity/opensync/libsync_svn.bb
new file mode 100644
index 0000000000..660b39aa42
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libsync_svn.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "LibSync is a GObject-based framework for more convenient use of \
+OpenSync in GLib applications."
+LICENSE = "LGPL"
+SECTION = "x11"
+DEPENDS = "glib-2.0 gtk+ libglade libopensync avahi"
+RRECOMMENDS = "\
+ libopensync-plugin-file \
+ "
+PV = "0.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/sync/trunk;module=sync;proto=http"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/sync"
+
+PACKAGES += "synctool"
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_synctool = "${bindir} ${datadir}"
diff --git a/meta/recipes-connectivity/opensync/libsyncml/build-in-src.patch b/meta/recipes-connectivity/opensync/libsyncml/build-in-src.patch
new file mode 100644
index 0000000000..d8106bdfc7
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libsyncml/build-in-src.patch
@@ -0,0 +1,19 @@
+---
+ CMakeLists.txt | 4 ----
+ 1 file changed, 4 deletions(-)
+
+Index: libsyncml-0.5.4/CMakeLists.txt
+===================================================================
+--- libsyncml-0.5.4.orig/CMakeLists.txt 2009-07-31 09:56:16.000000000 +0100
++++ libsyncml-0.5.4/CMakeLists.txt 2009-07-31 09:57:33.000000000 +0100
+@@ -72,10 +72,6 @@
+ CHECK_TYPE_SIZE( uint32_t UINT32_T )
+ CHECK_TYPE_SIZE( uint8_t UINT8_T )
+
+-# ensure out od source build
+-INCLUDE( MacroEnsureOutOfSourceBuild )
+-MACRO_ENSURE_OUT_OF_SOURCE_BUILD("${CMAKE_PROJECT_NAME} doesn't allow to build within the source directory. Please, create a seperate build directory and run 'cmake ${PROJECT_SOURCE_DIR} [options]'!")
+-
+ # find requirements
+ SET ( GLIB2_MIN_VERSION "2.12" )
+ SET ( OPENOBEX_MIN_VERSION "1.1" )
diff --git a/meta/recipes-connectivity/opensync/libsyncml_0.5.4.bb b/meta/recipes-connectivity/opensync/libsyncml_0.5.4.bb
new file mode 100644
index 0000000000..7feb5e0f18
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/libsyncml_0.5.4.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Libsyncml is a implementation of the SyncML protocol."
+HOMEPAGE = "http://libsyncml.opensync.org/"
+LICENSE = "LGPL"
+DEPENDS = "sed-native wbxml2 libsoup libxml2 bluez4 openobex check"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libsyncml/0.5.4/libsyncml-0.5.4.tar.bz2 \
+ file://build-in-src.patch;patch=1"
+
+inherit cmake pkgconfig
+
+PACKAGES += "${PN}-tools"
+
+FILES_${PN}-tools = "${bindir}"
+FILES_${PN} = "${libdir}/*.so.*"
+
+export VERBOSE=1 \ No newline at end of file
diff --git a/meta/recipes-connectivity/opensync/msynctool_0.37.bb b/meta/recipes-connectivity/opensync/msynctool_0.37.bb
new file mode 100644
index 0000000000..773166b3be
--- /dev/null
+++ b/meta/recipes-connectivity/opensync/msynctool_0.37.bb
@@ -0,0 +1,7 @@
+SRC_URI = "http://www.opensync.org/download/releases/${PV}/msynctool-${PV}.tar.bz2"
+
+LICENSE = "GPL"
+DEPENDS = "libopensync glib-2.0"
+HOMEPAGE = "http://www.opensync.org/"
+
+inherit cmake pkgconfig